The system clock does not update correctly in Windows 7 SP1.Secure DNS suspected


I’m using Windows 7 SP1 and my system time settings are not correctly updated even if the time zone is correctly set to:

(UTC+02:00) Athens, Bucharest
and the internet time settings are set to “”.

My systray clock is always set 3 hours behind after system start but the date is still correctly displayed.
I checked my bios settings and the bios battery and they’re ok, the bios time is correct. After this I suspected a software configuration problem and I tried to update the system time manually by pressing the manual update button but the system did not connect to the time server.
My next step was to uninstall the Secure DNS for the entire system and after this the system time was immediately set to the correct time.
Problem solved. But I still have some questions.

Why did Secure DNS cause this problem? It worked fine until octomber 2012. What happened? Does anybody know why? Did anybody happen to have the same problem?

Thank you.


I made my own investigation lately and I found out that what I wrote here just made the problem look worse but it was not the cause of it. The problem was the configuration of the Windows Time service which failed in some conditions in Windows 7 SP1. The solution was to configure Windows Time to reset for any error and to work for any user account not just for the Administrator account. It works now fine for three days so this is the real solution.

Secure DNS is a good product and it is safe to use for anybody and I recommend it. ;D And also I can install it back as it was before which is a good piece of news for me. :smiley:
In conclusion this topic is closed from my point of view.

Thanks for letting us know you’ve resolved the issue. :slight_smile:

I’ll lock this thread. If you wish it re-opened, PM an active moderator.