The Steam Store is being blocked by Comodo no matter what I do.

I’ve been dealing with this problem for well over hours by now it’s 5AM where I live that’s how long I’ve been dealing with an issue that really confuses me, and I honestly have no idea if this is the right section or not. It doesn’t matter what I change it just won’t allow steam to do anything. I even told it not to sandbox steam when prompted for that as well. I’m using the newest version of Comodo Internet Security.

No matter what I do steam shows this error even though I have setup Comodo to allow every single aspect of it in HIPS Firewall and Antivirus and even added steam to the trusted list in the file rating tab. But yet this error pops up every time. And it only goes away when I uninstall Comodo.

This error makes steam unusable for purchasing games. Comodo also blocks steam from installing games I already own.

Now I know this is Comodo’s issue as when I remove it everything works perfectly again. I first tried the new Comodo when they changed the UI and everything and added that widget. But I have never once had it work well for me. So I ended up switching back to 2012 Comodo and made sure the virus database was always updated before they had the new square shield. I don’t remember what version that was. But it worked perfectly in every aspect yet the new one will not to matter what I do to it. I’ve used Comodo for years but ever since this new change nothing has ever worked right with it and honestly I’m starting to get annoyed but I really don’t like complaining about a free service.

Until it started blocking my normal everyday programs despite the fact that I told it to trust them when prompted. I’m not a PC newbie I’ve repaired a lot of computers for my friends and I installed Comodo for them but now I hope they don’t start experiencing these issues when and if they update it. I’ve used Comodo since 2008 maybe even longer.

hello,

Can you please try adding the Steam Store to the Shellcoee Injections excluiosn list?

Open Advanced Settings->Defense±>HIPS->BEhavior Blocker and click on Exclusions link. In the windows that is opened, try to add add Steam Store executeables as exclusions. PRess OK on all the opened dialogs and restart Steam.

Pls let me know if this helps.

Thank you! It at least lets me install and update games now. But the store still doesn’t work. I’m still not sure what’s wrong with it. It never loads a page while I have Comodo installed now. it also stopped showing the error code -137 though. It’s still an issue with my Comodo setup as the steam store isn’t down and still won’t load a page even though all of it’s exe’s are trusted in the firewall so I can’t really tell if it’s still HIPS or the firewall now.

What is the operating system? And can you also tell me your CIS version?

Hi RissanCloud
Can you please remove C:\windows\system32\guard32/64.dll and C:\windows\syswow64\guard64.dll (for 64 bit OS) and try it?
If this still does not help, it is appreciated if you can remove C:\windows\system32\drivers\cmdguard.sys, reboot and try again.

Thanks
Haibo

That dll can’t be removed unless Comodo is uninstalled or disabled from what the error message is telling me. I already know steam works if Comodo is completely disabled or uninstalled. I should be using the latest version of Comodo currently out on the main website and my OS is Windows 7 Home Premium 64 bit.

I’ll try and remove the dll later though I can’t currently as I’m really busy today. Thanks for taking your time to help me it’s appreciated.

What do you mean by" COMODO is disabled"? You mean antivirus is disabled?

Hi RissianCloud,
Try in Windows safe mode.
Start your computer in safe mode-Microsoft

Kind regards.

I’m sorry I haven’t responded for so long I’ve been really busy. But I managed to locate the issue. The sandbox is what was causing it. No matter what I told Comodo to do it kept auto sandboxing steam even if I told it not to. So I have HIPS Antivirus and Firewall all working with steam now I had to disable the sandbox though as it doesn’t ever ignore steam. I have no idea why it’s like that. It ignores other programs fine.

I would like to use the auto sandbox feature if it can ignore steam but if not I’m fine with just HIPS and the virus/firewall protection.

Hi RissianCloud,
Note: For use with 100% trusted files only.
Add the files to the Behaviour Blocker exclusions list.
Define exclusions for behavior blocking-Comodo Help

Kind regards.
Edit: Apologies, looking back through the topic it appears you have already tried this. :-[

Adding steam to the exclusions did not solve the issue. Steam will get autosandboxed even when Comodo says it’s a Trusted app and even if it is added to behavior blocking exclusions.

Try making a HIPS rule for it and make sure it is on top of the list. A HIPS rul should normally override the sandbox.

I’m having almost the same problem with comodo and steam store. I can play, but the steam store has been blocked, even if I disable comodo (Firewall, Auto-Sandbox, HIPS and Viruscope), I still can´t use the store and the community page on the app steam. I can use just if uninstall comodo from the computer.
My system it´s Windows 7 x64 and I have the last version of comodo and steam.
I don’t know how fix this, I need help and thats is my last try before uninstall comodo definitely =(

Edit: I Already did the rules for steam.exe on firewal, Sandbox and HIPS

Do the logs bring any insight in what is blocking?

Try adding it to the exclusions of Detect shellcode injections (i.e. Buffer overflow protection).

Hi Eric. I tried add steam.exe to the exclusions of Detect shellcode injections like you said, but didn’t work.

I do turn off steam, deleted all logs and turn on again.
I don’t know if it’s normal, but the “configstore_log” stay doing the line:

         "Flushed store 'userlocal' to 'C:\Program Files (x86)\Steam\userdata\30088888\config\localconfig.vdf'"

The rest look like normal for me, except in the “appinfo_log” where was 537 access tokens denied and an error in the “debug.log”, but I don’t know exactly what means. I copy below same logs.

Thanks for your help

“configstore_log”

[2016-07-15 14:33:03] Loaded store ‘install’ from ‘C:\Program Files (x86)\Steam\config\config.vdf’ successfully
[2016-07-15 14:33:03] Loaded store ‘install’ from ‘C:\Program Files (x86)\Steam\config\config.vdf’ successfully
[2016-07-15 14:33:03] Loaded store ‘userlocal’ from ‘C:\Program Files (x86)\Steam\userdata\30088888\config\localconfig.vdf’ successfully
[2016-07-15 14:33:04] Flushed store ‘userlocal’ to ‘C:\Program Files (x86)\Steam\userdata\30088888\config\localconfig.vdf’
[2016-07-15 14:33:05] Flushed store ‘userlocal’ to ‘C:\Program Files (x86)\Steam\userdata\30088888\config\localconfig.vdf’
[2016-07-15 14:33:07] Flushed store ‘userlocal’ to ‘C:\Program Files (x86)\Steam\userdata\30088888\config\localconfig.vdf’
[2016-07-15 14:33:07] Flushed store ‘install’ to ‘C:\Program Files (x86)\Steam\config\config.vdf’
[2016-07-15 14:33:07] Roaming config - failed to load write-aside store from ‘C:\Program Files (x86)\Steam\userdata\30088888\config\sharedconfig.vdf’
[2016-07-15 14:33:08] Roaming config - read via RemoteStorage().FileRead
[2016-07-15 14:33:08] Roaming config - integrating write-aside store into cloud store
[2016-07-15 14:33:09] Flushed store ‘userlocal’ to ‘C:\Program Files (x86)\Steam\userdata\30088888\config\localconfig.vdf’
[2016-07-15 14:33:09] Flushed store ‘userlocal’ to ‘C:\Program Files (x86)\Steam\userdata\30088888\config\localconfig.vdf’
[2016-07-15 14:33:11] Flushed store ‘userlocal’ to ‘C:\Program Files (x86)\Steam\userdata\30088888\config\localconfig.vdf’
[2016-07-15 14:33:21] Flushed store ‘userlocal’ to ‘C:\Program Files (x86)\Steam\userdata\30088888\config\localconfig.vdf’

“bootstrap_log”

[2016-07-15 14:33:03] Startup - updater built Jul 8 2016 14:45:17
[2016-07-15 14:33:03] Verificando a instalação…
[2016-07-15 14:33:03] Verification complete
[2016-07-15 14:33:04] Background update loop checking for update. . .
[2016-07-15 14:33:04] Verificando se há atualizações…
[2016-07-15 14:33:09] Download skipped: /client/steam_client_win32 version 1468023329, installed version 1468023329
[2016-07-15 14:33:09] Nothing to do

“appinfo_log”

[2016-07-15 14:33:07] ProductInfoChanges: change number 2105265->2105278, apps: 0/7, packages: 0/4
[2016-07-15 14:33:07] UpdatesJob: requesting 537 apps, 0 packages (meta data, 0 prev attempts)
[2016-07-15 14:33:08] UpdatesJob: requested 537 access tokens, 0 received, 537 denied
[2016-07-15 14:33:08] UpdatesJob: finished OK, nAppsUpdated 0 (0 KB), nPackagesUpdated 0 (0 KB)

“connection_log”

[2016-07-15 14:33:03] Log session started
[2016-07-15 14:33:03] [0,0] SetSteamID( [U:1:0] )
[2016-07-15 14:33:03] CCMInterface::OnNetworkDeviceStateChange – Saw device up, connecting to Steam
[2016-07-15 14:33:03] [0,0] SetSteamID( [U:1:30088888] )
[2016-07-15 14:33:04] [0,0] SetSteamID( [U:1:30088888] )
[2016-07-15 14:33:05] [1,2] Connect() starting connection (eNetQOSLevelHigh, 208.78.164.14:27018, UDP)
[2016-07-15 14:33:06] [1,2] ConnectionCompleted() (162.254.193.44:27018, UDP)
[2016-07-15 14:33:07] [1,2] RecvMsgClientLogOnResponse() : [U:1:30088888] ‘OK’

“Debug.log”

[0715/145931:ERROR:child_process_launcher.cc(443)] Failed to launch child process
[0715/150221:ERROR:child_process_launcher.cc(443)] Failed to launch child process
[0715/150402:ERROR:child_process_launcher.cc(443)] Failed to launch child process
[0715/150405:ERROR:child_process_launcher.cc(443)] Failed to launch child process

It worksssss!!! o/

I added not just the steam.exe to exclusions of Detect shellcode injections, but all steam folder and works!!!

Thank you very much!!

I am sorry when I said logs I meant the CIS logs. Could you check teh various logs to see if a component interferes with Steam. When it does could you post a screenshot of that log?

Thanks Eric, I search for the steam logs and found many files could be has been blocked by Comodo, then I added all steam folder and it works.
I dont know whitch then have been blocked, but it works. :smiley:
Thanks again.

To what exclusion did you add the Steam folders? From the buffer overflow/shellcode detection or the AV?

To exclusions of Detect shell code injections from HIPS configuration