"The Network Firewall is not functioning properly."

Hi All,

Here’s the situation. I once installed just the Firewall while I had Spyware Doctor and Registry Mechanic on my system. Everything worked great. I have since decided to try using just Comodo products in lieu of Spyware Doctor stuff. So… I uninstalled EVERYTHING (AntiVir, Reg Mech, CPF) and rebooted. I then downloaded the newest CIS installer from Comodo’s website and did an install of all Free CIS products in that installer. After reboot, I get the “network firewall is not functioning properly” error in Comodo. I have tried:

  1. Running as Administrator
  2. Running in Compatibility mode with Vista SP1
  3. Installing JUST Firewall (no Defense, no AntiVir)
  4. Installing Combinations of Firewall, Defense, AntiVir
  5. Running installer without selecting “as Admin” or in Compatibility mode.
  6. Using the Batch Process cleaner AFTER uninstalls before trying things again.
  7. Using the OLD installer (just one version prior to the installer available on Comodo’s website) and repeating steps 1-5

The result is… NO LUCK!

I am running Retail Release Windows 7 Ultimate x64. Any ideas?

Thanks a bunch!

UPDATE I forgot to mention that I do try the built-in Diagnostics/Repair tool after each install attempt and it Fails to correct the problem… every time. Lastly, Windows Firewall and Defender are both turned off.