The Network firewall is not functioning properly

Like many others, I have been plagued with this error since installing CIS version 3. I have read and applied all of the support suggestions but the problem persists. I am running Windows XP, SP 2, and have AVG Anti-Virus installed. I did not install Comodo anti-virus. The Windows system log shows error 7026 on the Inspect driver, and no entries in the Defense+ events log. I did a completely clean removal and reinstall of the latest Comodo version – no change. Look guys, judging by the number of posts on this exact problem, Comodo has a serious bug and it doesn’t look to me as if anyone is trying to fix it. How about making some effort to get this fixed, rather than continually reposting the same ineffective suggestions!

Does this FAQ help you: .

No, it does not! As I mentioned in my original post, I have tried all of the suggestions related to this problem.


We are gonna take a look to see if there are some old drivers of your previous security programs are still around. Go to Device Manager → View → show hidden devices → now look under Non Plug and Play drivers → when you see a driver that belongs to your previous security programs click right → uninstall —> do this for all drivers → reboot your computer.

When the problem persists make sure there are noauto starts from your previous security programs download Autoruns and run it.

This program finds about all auto starts in Windows. This tool can therefore seriously damage Windows when not handled properly. After starting go to Options and choose to hide Windows and Microsoft entries and then push F5 to refresh.

Now check all entries to see if there are references to your previous security program. When you find them untick them. After unticking reboot your computer and see what happens.

You have such a poite way of asking for help, I’m embarrassed no one has come to your aid.

Please provide details and not generalities, perhaps then, we can help.


I was pretty sure I had done that, but I did find a PC Tools driver hanging around, and a Zone Alarm program but apparently no driver associated with it. This is a software research and testing machine, so I have had a lot of different things installed on it over time. There’s quite a few drivers, and it’s often hard to tell what they belong to, but I’ll keep picking away at them and see if I can get Inspect.sys to load.

I keep the startup stuff to a minimum, and there’s nothing in there related to previous installations.

I have some things running right now that I can’t interrupt. I’ll let you know if any of this has made a difference when I can reboot.


Keep us posted.

I removed everything that I recognized as related to past security products–no help! Are you quite sure that this problem is caused by driver incompatibility, or are there other known products? How about AVG Anti-Virus; any known problems with that?


I am not aware of any problems with AVG. Did you compare the inspect.sys as described?

Yes. I did a totally clean reinstall yesterday–deleted everything COMODO from the registry even. Then I even copied inspect.sys from the Repair directory, even though it appeared to be identical with the one in the drivers directory.


I sent a PM to Ronny, the maker of the FAQ, as that what he asked in the FAQ.

Can you tell me what is the COMODO Application Engine. It’s on the driver list, but greyed out; the status shows “device not connected to computer.” Is that normal?

I also checked the COMODO Network Engine. It wasn’t reporting any errors, but it wasn’t started. I tried to start in manually, and the status now says Started, but COMODO still shows the network error. Any ideas?


I was getting good response on this until July 6; nothing since then. I have questions pending. What’s happened?


I have no idea what the COMODO Application Engine is. Can you look at its properties and see what file is related to it? Or post a screen shot with that information? What version of CIS are you using?