The network firewall is not functioning properly

Hi everyone!

Basic Info:
I am new to this forum.
I tried to search forum for my problem so I hope I am not posting already answered question.
I have never used any comodo software before.
I have embaded security chip in my thinkpad nb whose status is checked every time during windows boot.

I downloaded and installed CIS_Setup_3.9.95478.509_XP_Vista_x32.exe
During reboot after installation system got stucked at security chip status checking. It was not frozen (animation did not stop) but there were no further activity just checking and checking. I turned off and tried to boot it again with “last configuration that works” windows boot option and it worked. After boot complete there was installed CIS. In summary tab in System status it said “the network firewall is not functioning properly”. I ran diagnostics with result “There is some problem with your instalation. Would you like to fix them?”. I chose yes and was directed to reboot. During this reboot tha same story happens again as mantioned above. I goes to desktop by last-configuration-that-works again and found the same firewall-not-functioning-properly message. So I found this
I followed the instructions with theese results:
c:\windows\system32\drivers\inspect.sys - file is present in my system
In Event Viewer I found an error messages whose timestamps matches my attempts to fit an issue.
Error message with event ID 7000 was always immediately followed by another error with event ID 7026. There were four of such pairs in list.
But I have correctly named file on my disk (ad event id 7000)
I checked checksum of my instance of file and that at c:\program files\comodo\comodo internet security\repair\inspect.sys and they were the same…

any help appreciated :frowning:

Can you show us a screenshot of your Defense + logs? They can be found under Defense+ → Common Tasks → View D+ events.

I think the screenshot is not needed because “There is nothing to show” in that log. Actually I looked through all logs available and they are all clear. It seems weird to me but on the other hand I haven’t done anything yet. Neither antivirus scan…

Some more info: I tried to run a scan now but got an error message:

Update failed. Error code 0x80004002. No such interface supported.

The same with manual update of virus databaze. I’ve seen this error message somewhere here on forum so I will try to read it…

And maybe is worth of mentioning that I am now runing second instal. After first occurrence of problem I tried reinstal first. I forgot to inclue that in story.

Is this the first time you installed Comodo? What other security programs are running in the background on your system? What OS are you on?

I have winXP sp2. I ran Norton security at first. Then my antivir protection expired so I turned it off and installed NOD from my friend. Then it expires too so I was looking for some free solution. First I tried free version of AVG. It was fine but I realised that it would be better to uninstall norton as well and find something which is antivir and firewall togather. I found comodo security. I uninstalled avg and norton (no more security programs I am aware of. Windows firewall turned off permanently) and installed comodo. And that is the point where my story began.

We are gonna take a look to see if there are some old drivers of your previous security program still around. Go to Device Manager → View → show hidden devices → now look under Non Plug and Play drivers → when you see a driver that belongs to AVG, Norton or NOD click right → uninstall —> do this for all drivers → reboot your computer.

When the problem persists make sure there are noauto starts from your previous security programs download Autoruns and run it.

This program finds about all auto starts in Windows. This tool can therefore seriously damage Windows when not handled properly. After starting go to Options and choose to hide Windows and Microsoft entries and then push F5 to refresh.

Now check all entries to see if there are references to your previous security program. When you find them untick them. After unticking reboot your computer and see what happens.

Does this help?

I found some symantec drivers among Non Plug and Play drivers. I uninstalled them and rebooted but not helped. I found autoruns with the same names as drivers I uninstalled so unticked them. After reboot no change. Then I tried to “check for update” in miscellaneous and get error 108. I looked through forum and I found this thread so I downloaded and ran norton removal tool but CIS still stating something is wrong with my installation. And after repairing it the same booting problems…

It would be good to know what change(s) is performed by diagnostics as a reparation. Isn’t there some diagnostics log or something?

Now I installed new version CIS_Setup_3.10.101801.529_XP_Vista_x32.exe and problem persists.

But new potentially important info. I described that EventViewer stuff in first post. When I was reading this FAQ
I was not registered to forum yet so I didn’t see pictures attached. Now I looked at them and I saw that my errors 7000 and 7026 was not the errors about comodo soft.

Message eventID 7026 was not about inspect.sys not found but about symtdi.sys not found. At that time symtdi.sys was installed (autorun present in registry) but not present on disk anymore after norton uninstall so this error was generated after each boot. Now this error is not generated any more because I uninstalled symtdi.sys and some others symantec related drivers as was advised.

Message eventID 7000 in picture attached to FAQ linked above shows this message “The COMODO Internet Security Firewall Driver service failed to start due to the following error: …”. My message eventID 7000 shows “The Automatic LiveUpdate Scheduler service failed to start due to the following error: …” which has probably nothing to do with my problem.

I hope this will help.

Can you put D+ to Training mode and reboot. Only do this when you are sure you are free of malware as in this mode will learn all rules. To put D+ in Training mode go to Defense + → Advanced → Defense + settings.

I found an old topic about similar problems with computers with a security chip: . It might be of help.

Keep us posted.

First I’ve read thread you posted. I was really using an older version of Client Security Solution so I installed the latest but still did not work. Then I tried reinstall CIS again (installation with new security solution, maybe it has no sense but who knows). Before reinstall I remembered that during first install oif CIS ever there were some more procedures than during the others (probably virus database update before systme scan. I remeber just gauge bar with label showing file names with 1222 and counting :slight_smile: ) Because of this I ran cis removal tool from this thread and then installed cis again. Tried a boot and the same stacked boot again. Then when I got to the system cis downloaded some new update itself. A try with diagnostics fixing problem again and D+ in Training mode followed. After reboot nothing better…

Oh my … I feel like I am making this up to test your services :slight_smile: But I don’t…

I am kinda stuck so I asked the other mods to take a look and see if they can help.

To be honest I didn’t think the problem would be solved. I didn’t really think that somebody would interests about such weird looking problem. So I already thank you for help and so quick response!! 8)

I have no idea how security programs wokr inside so maybe it is useless. But as I wrote maybe some log of changes done by diagnostics would be of help… I mean it just like suggestion for the future…

Hi. Are you completely sure everything from your old installations has been removed. I ask because symtdi.sys is a symantec driver. Ensuring that all remnants of these old programs are removed is the first place to start.

Second, is it possible to temporarily disable the security chip?

I don’t know much about drivers stuff. My claim that no other security driver is present in my system is based just on Non-Plug and Play Drivers list. I do not recognize any security driver in it. To make sure I am attaching a copy of the list.

I found an option of deactivating a security chip in Client Security Solution…

[attachment deleted by admin]

There was an issue with this last year here maybe that might help. Does deactivating the chip during install help?

Try the Norton removal tool if you haven`t allready


I’ve read that thread. The only result was to install the latest version of Client Security Solution. I already did that and it didn’t help. I also ran norton removal tool. But I didn’t try deactivating chip during install yet. My uni keeps me busy right now so I don’t have time for this for now. It is going to finnish in few weeks than I will reinstall whole windows because I am runnig it for about three years now and maybe there is some unusual registry entry or file somewhere. Then I try all this again and post here if it would help or not.

I wasn’t here for two or so days and I my thread was already in the middle of second page in thread list. Keep this place alive your help is appreciated :wink:

So I tried to deactivate chip during install anyway. It didn’t help and moreover my usual last-configuration-that-worked way to get to desktop when chip checking is stucked didn’t work neither. It is because when rebooting after install it worked because of deactivated chip. So when I tried to reboot after turning chip on the last configuration that worked was that with deactivated chip which is the bad one. So I went to safe mode and uninstall comodo (client security solution to deactivate chip again was unavailable). After that rebooted and I got to desktop but interestingly chip was activated without I told it to be…

hm weird … I shall try windows reinstall as I said…


I had the same problem with a new installation of COMODO but I could fix it. I went to the “Device Manager” as it was propsed in a post earlier, activeted “Show hidden devices” in the “View” menu item and among the “Non Plug and Play drivers” I looked for the “COMODO Firewall Pro Firewall Driver”.

I opened the properties of the driver and changed to the “Driver” tab. The “Statup” type was set to “Boot” in my case and I changed it to “System”. When I rebooted the machne the firewall worked correctly.