The Network Firewall is not functioning properly!

Hi, I’m having problems getting COMODO firewall to run properly, I get the message ‘The Network Firewall is not functioning properly!’

I’ve ran the diagnostics which returned no problems. Uninstalled Avast, turned windows firewall off, and uninstalled then reinstalled CFP reinstalled network card drivers.

CFP blocks all network activity while its running, unless the firewall setting is put to disabled.

Please can you help? I’ve ran the comodo config report script and pasted the output below…

Regards

Irid

Edit by MOD: Removed text added as attachment

[attachment deleted by admin]

It appears it doesn’t even detect you network/interface, you network zone show’s only the local loopback but should also contain you “normal” network interface with ip and subnet.

Can you check Misc, Settings, General, Automaticaly detect new private networks ?
Or try to make it yourself, go to Firewall, My network zones, Add, A new network zone.
Give it a name, select that name, choose add, An ip address/mask and type your ip and subnet there.
Reboot and give it a try ?

Tried adding my subnet/mask to the firewall setup, but it hadnt remmebered it after reboot, and still not working, so i tried again same again. The NIC is on and working i can connect to my router and further abroad across the internet, that works great, just CFP dont detect it, doesnt even appear to try. And since last post, i noticed D+ has detected no running processes either.

Thanks for something to try at least.

Hello Irid,

Post us the list of other programs you have active, maybe there’s a conflict with other security tools ?
Looks like the setup failed due to some other program messing this up.
Maybe uninstall and then disable all other active protection fw/av/hips and so on and then install again ?

Hallo Irid,

I guess this issue could be caused by some CFP drivers error.
Can you please run the script I attached to check if the drivers are running?

Maybe uninstalling CFP and installing it again could solve this issue.
You can backup your current configuration from Miscellaneous|manage my configuration.

[attachment deleted by admin]

See Here.

Scroll down to the bottom to download the batch. First remove CFP 3 from add/remove programs. Then run this batch & reboot, Download a fresh copy. It SHOULD solve the issue in most scenarios.

Josh

(:SAD)

Tried the suggestions, to no avail. Thanks for them, its always worth a try. I am a software developer of 20 years experience, so i dont think i’m missing a trick with you’re scripts.

So i wiped the harddrive, reinstalled XP patched SP3 onto it, loaded device drivers and before any other 3rd party software i loaded CFP, it was non functional. So I can only conclude theres 1 or more of 3 issues, XP is faulty, CFP is not compatible with my hardware, or the moon has left its orbit and my PC is mourning its absence therefore refusing to cooperate.

I dont want to go back to ZoneAlarm, but it works for me and thats what counts most. So any other suggestions would be welcome.

Regards

Irid

It is quite strange…

Well irid I think wait till next CFP 3 update soon…

Josh

Irid installing the OS from scratch and testing CFP again was the ultimate solution to test this issue.
I thank you for taking such efforts but I guess adding few more details could help narrowing down the possible causes.

Since you suspect an hardware incompatibility please report you HW as well.
Please confirm the status of CFP sys driver running the script I attached in my previous post.
If some of them cannot be loaded causing that issue an error code could help further and increase the chances that a new CFP version could fix this issue.

Installer Exe : CFP_Setup_3.0.25.378_XP_Vista_x32

Attached SysInfo Export.

Output from testme.vbs

CMDGUARD.SYS File Version: 3.0.23.359 True Running
CMDHLP.SYS File Version: 3.0.23.359 True Running
INSPECT.SYS File Version: 3.0.23.359 True Running


One thing i noticed when installed on another machine, it popped a window up with regard to obtaining lifetime liscence, that has not happened on this machine.

Regards

Irid

[attachment deleted by admin]

This output means these deivers were started and running. Cfp.exe and cmdagent.exe were up and running too in you previous reports.
I’m clueless as to the reason behind that error in CFP status bar and I guess only devs could think about other reason behind that error.

Please confirm you didn’t saw the AVSMART warrantry dialog on the machine with faulty CFP. This should mean the installation quit bebore that dialog.

I didnt see the AVSMART warrenty dialogue as you put it (is that the one that mentions lifetime license) The installer apparently completes though, it asks for a reboot to complete installation and when its rebooted i got a dialogue offering to upgrade to Plus! version. This is irrespective of wether i do a scan for nasties as offered during the installation, i just click yest, i’m sure the machine is clear, having wiped the harddisk and not touched any 3rd party software other than official HW drivers and CFP installer.

My mistake then. The installation apparently completed without issue.
awsmart warrantry dialog is the plus version one.

Thanks for trying to help - I’m gonna go with ZA for a while, and try next release of CFP, i like cfp got it running on 2 laptops and the kids’ pc just not on this my games machine :frowning:

I had the same error. Couldnt uninstall it as it did not show up in Add/Remove programs. So I installed it through safe mode an all seems well right now. Shows up in add/remove and in the programs list. No errors.

Working.

The solution is connected either with XP Service Pack 3, or Basic/Dynamic disk setup.

Previously I reformatted and installed XP Pro, SP3, Drivers then CFP on Dynamic disk setup. Failed
This time I reformatted and installed XP Pro, SP2, Drivers then CFP on Basic disk setup. Worked!

Not hugely helpful to track the cause, but its something.

Anyway, I’m a happy bunny now :BNC

Regards

Irid

If it is any support to the solution, I’ll bet on it being Dynamic Disk being used on the machine.

I’ve been able to install CFP v3 on standard XP SP2, and SP3 clean installs. CFP runs no problem.

On the several machines that are SP2, and have dynamic disks defined for user data (not application installs), CFP v3 fails with symptoms as you’ve described. CFP v3 has not been installed to a dynamic disk, just a basic disk. Died silently during the install as you described. Those machines run CFP v2.4 instead.

Whether this is the actual cause of the problem, I have no idea. But thank you very much for the additional data point.