"The network firewall is not functioning properly" [Merged Threads]

I just installed v3 and I get the message “The network firewall is not functioning properly!” on the bottom of Comodo. HELP!!!

(XP 32 bit)

I got a similar message about Defense+ after I had made several HIPS rule modifications. There was no other indication that there was an error condition anywhere and the firewall and HIOPS appeared to be operating and trapping correctly. After a reboot it was all fine.

Sorry I can’t add anything concrete.

Ewen :slight_smile:

I got this same message when installing Comodo Firewall Pro 3.0 and choosing to install the Advanced Firewall with Defense+. Then I uninstalled Comodo Firewall Pro 3.0 and reinstalled it choosing the option to only install the Basic Firewall. This time I did not get the ‘network firewall not functioning properly’ message and the System Status showed that all systems were active and running. But I wanted to be able to utilize Defense+. So I went to the Defense+ tab and under Advanced Settings I tried removing the check from ‘Deactivate the Defense+ permanently (Requires a system restart)’ and then I rebooted my computer. After it finished rebooting, I checked the Comodo Firewall Pro 3.0 interface under the Summary tab and found that the message stating ‘The network firewall is not functioning properly!’ was gone. A green circle with a check in it was there in place of the red circle with an X in it. Also the message that was there stated that “All systems are active and running”. This was the only way I could get the Defense+ to install without getting the ‘network firewall is not functioning properly’ message on my computer. I did not have to do this on my wife’s computer. I was able to install Comodo Firewall Pro 3.0, choosing the ‘Advanced Firewall with Defense+’ just fine the first time on her computer. Both computers are running Windows Vista Ultimate. Try this and see if it helps.

installed today, but get the system status that network firewall is not functioning properly, I press the run diagnostics which say it has found problems do you want them fixed I say yes it then reinstalls drivers that vista gives a prompt>> Have done clean install and reinstall.

I say allow, then it gives a dialog box saying failed to fix do I want to create a report which I have done/??

can anyone help

have tried safe mode removal and installing a s a basic mode both di d not work.


tried to remove and reinstall in safe mode, followed three hours of bsods, reinstall, with missing filesso unable to uninstall again.

What a mess, not for the feint hearted???

I have a whole bunchof mini dumps if any of you developers would like to take a look-- still very much beta.

I have had this problem on the final release version, on vista ultimate, have also installed on a second xp pro fine…

I have done the above- and reinstalled via safe mode which gave me alot of problems and a few bsod when restarting normally-finally I managed to do a system restore- which restored the system without the uninstall files so had to safe mode and then reinstall to be able to uninstall-- as you can see a bit of a nightmare…

Have many mini dumps and comodo report files if anyone is interested.



I have tried the beta and longed for the release of the first firewall for windows Vista x64 editions. I hoped that comodo shold work but no. I expect that you should try the firewall in the operating systems that you say it works for.

And I have followd all tips you gave me. If I run the diagnostic test It says that the firewall couldn’t fix the problems (I have never seed a working diagnostics tool). It adds a couple of drivers that doesn’t change anything.

I expect you to alove the problem or stop saying that this s**t is Vista compatible. Or give me a link to a Vista x64 compatible firewall.

edit: btw, I’m talking about V3…

Well I tried uninstalling and reinstalling without Defense Plus but it still kept Defense Plus there. So I’m very disappointed with Comodo. Frankly this new product is crap IMO. (:AGY)

thanks for moving this gibran would have preferred some help. as no matter what I try i cannot get this firewall to install with the network functioning.

Please anybody have any ideas??

Defense is part of the program “Comodo v3” you just installed :P. It can’t be uninstalled. Only disabled.

Back to 2.4. 3 just sucks.

Same message - “The network firewall is not functioning properly!” - after installation of Comodo Firewall Pro 3.0.

  • After update “Diagnostics” shows that everything is working correctly , before it “can not fix the problem” + vista’s message telling smth about that driver is not certified, do you want to install anyway.
  • Activation/disactivation of Defence+ does not change anything.
  • Traffic is not monitored, no statitistics. But sometimes appear baloon messages.
  • on line tests show that stealth mode does not work.
  • I also installed it on XP, evertynig is OK.
    Before using Comodo i was on Zone Alarm.
    OS - Vista Professional 32x

where is the problem? some special settings in Vista to do or Comodo’s bugs ?

i got this proglem to. tried Diagnostics but nothing works…

At present, no matter what I do, the firewall always install with the network firewall not functioning and not being able to repair it…

It is very quite here about it>> Come on Developers are you really not interested in this??

I have it working on xp fine but vista have this problem spent many hours uninstalling and reinstalling but always the same problem??

What is going on??

It seems the release was a bit premature. I too got the error message on my first installation attempt. I uninstalled, cleaned up the registry and filesystem and reinstalled with default options. It now works as intended. Could be a minor bug in the installation routines. I’m sure the Devs are already aware of this, but I’m posting another bugreport :slight_smile:

Hang in there everyone!

“It seems the release was a bit premature”

that rings a bell remember the hal.dll fiasco?

It will be a great product for some but some official interest or response to this problem would be good?

It’s forthcoming. Please allow some time for the Devs to figure things out and post a solid feedback.

That’s not fair.

The hall.dll problem could only be fixed after user feedback, simply because Comodo were unable to “recreate” it in their tests. You can’t blame them for that.