The Firewall no longer enforces rules or asks about new applications

My firewall filtering used to work perfectly, but at one point, things went wrong.

I have a lot of app-specific rules. Nowadays the firewall seems to be very selective (sometimes it enforces those rules, sometimes doesn’t), and oftentimes doesn’t ask me about new applications (it lets them connect by default!).

This is quite bad. I checked the Firewall Settings and don’t see any reason for this. The only setting I’m unsure of is the top one – it’s set to “Custom Ruleset”, but seems to be intuitively correct.

I want the firewall to enforce all existing rules and ask me about every non-regulated connection attempt. How can I achieve that again?

Hi, I’m no expert, but yes, Custom Ruleset prompts you when a firewall event happens. So try:

  1. Export your profile out to a file (General Settings > Configuration > Export)
  2. Change your configuration to one of the onboard rulesets in General Settings > Configuration > Comodo Firewall Security
  3. Then reimport your settings from the file and activate.
    Or you could try a full download of the latest Comodo, uninstall your old version and reinstall with the new version.

Hope this helps.