The firewall failed

I upgraded UltraEdit manually for testing under Windows 7 64bit,the latest CIS Premium and “Safe Mode”.

If adding Uedit32.exe to Blocked Application List,normally UltraEdit will prompt “can’t connect server”.

But sometimes the firewall failed and could’t block Uedit32.exe,which could connect randomly.

When rebooting the computer,this problem is solved.

I have not found what specifically made this problem. With the habit of my using computer,the firewall always fails after 10:00 pm.

I think it is the compatibility problem to 64bit OS,some softwares like UE maybe run under WOW mode and install in the program files (x86) file.

Please forgive my bad English. ;D


Would you explain what you have created as a rule for Uedit32.exe and also whether or not you have a check in the box in the image.

[attachment deleted by admin]

Yes,please look at my setup.This is the “Network Security Policy”.

Winzip and realplayer are set by “Define a New Blocked Application”.
UltraEdit is set manually by default Predefined Policies “Blocked Application”.

But my firewall still doesn’t work,above three applications can still connect internet.No records,no pop-ups.(When rebooting,the firewall runs well and has blocked records.)

Only I set firewall “Block All”,they can’t connect internet.

[attachment deleted by admin]

I don’t see anything obviously wrong with you configuration. I recreated the set-up and it blocks UltraEdit the way I would expect. Have you run More/Diagnostics.

[attachment deleted by admin]

glad, show tab “Destination Address” and “IP details” of the rule for uedit32.exe.

And also show screenshot of Firewall Log, because it can be another exe-file of UltraEdit which makes updates.