The firewall doesn't protect anything :(

Hello,

Comodo was running fine, then I uninstalled it as I had network problems and wanted to be sure that they didn’t come from Comodo. After the problems were solved, I installed again Comodo. I asked an “automatic configuration”. Reboot… Then the Comodo icon is static (even if I ask the animated icon), the security level is at “Custom” (I cannot change it, whatever I chnage it stays at “Custom”), BUT :

1- All the controls (Application monitor, Component Monitor, etc) are OFF. When I ant to turn them ON, I go to their window, and the “Turn on” option doesn’t change anything, the status stays with the “turn OFF” enabled. The ADD buttons do not work.

2- The activity logs do not show any activity

3- I can use any program, Comodo doesn’t ask anything

In short, Comodo doesn’t protect the computer.

I installed/UNinstalled/REinstalled using the Uninstall Comodo feature, with the reboots when asked.

The Comodo main window correctly shows my adapter, local and internet and IP addresses. I have no other firewall running, the Windows one is turned off.

After I reboot (after re-installation), about 5 minutes later popup tell that applications are inactive and that “a reinstallation can solve the problem”. I re-installed already 3 times and nothing changed.

Ah! I noticed that when I RE-installed it, Comodo didn’t ask my licence number. So it seems that the UNinstall doesn’t really clear all data, but I don’t think the problem can come from here…

So, what must I do ? :frowning:

Thank you!

You are not alone. It happen with me about three times.
Reinstall helps but it’s not right way to solve problem so i have returned to ZA.

The license file will remain behind, yes. But that won’t impact the operation of the firewall.

You are most likely looking at the need to clean out the registry, possibly remove some legacy keys.

I generally recommend using a product like RegSeeker (free) or ccleaner (also free); be sure to use the auto-backup option before deleting any registry keys. You may also use Windows’ built-in regedit to manually find and remove entries.

hope this helps,

LM

Hi,

everything the OP told you happened to me as well. I installed the firewall once and it seemed to run fine. I had to uninstall it because of some other, unrelated matter and ran into the same problem so many others here have. It won’t run. After a few minutes three pop-ups appear:

“The Comodo Network Monitor is not active. Reinstalling the application may fix the problem”
“The Comodo Application Monitor is not active. Reinstalling the application may fix the problem”
“The Comodo Application Agent has an incompatible version. Reinstalling the application may fix the problem”

The funny thing is: If I exit the program, then restart it and put everything to “Block all” it works! (Windows still says it’s not there, though).
But of course I don’t want a firewall I have to restart whenever I start the computer… and can’t configure myself… :frowning:

I worked my way through this forum and tried everything to uninstall the program, but not even ccleaner AND a complete new installation of XP Home (inkl. SP2 and all updates) got everything off my computer!

Could someone tell me where all the registry keys are I have to delete - or is there a patch or something to for this problem? I would really like to use this software, but I’ve already spent 2 nights uninstalling and reinstalling this thing… I can’t take it much longer. :-\

Try searching the registry manually for Comodo entries…

Go to Start/Run and type in “regedit” (no quotes). Under the Edit menu there’s a search option. Try Comodo, CFP, etc. If you have trouble deleting any keys you find, you may want to right-click, select Permissions, and make sure you have full control.

I advise that you use the Export feature to backup the registry before making any changes…

LM

Why can’t they incorporate this in to the uninstaller? Most firewalls have this when you uninstall it. No one likes to mess with the registry,I know I don’t. And I have to uninstall CPF to update my Anti virus program.

Thanks, Little Mac, but I have done all this before (a couple of times, actually) and, judging from the program’s behaviour, there seem to be more registry entries. That’s why it would be helpful to have a list of those the program adds, so you can search for them directly.

I have yet to see a firewall (or any software, for that matter) that completely uninstalls in Windows. There are always leftover bits & pieces. Comodo actually does a better job than a lot of others. Some companies (such as Norton, Zone Alarm) have had to produce special “after-the-fact” removal tools for their products, as the systems are so trashed after an uninstall that no other product can be installed without problems. Unfortunately, there are a lot of reports that these tools don’t work very well either. I think that these difficulties are because firewalls are forced to embed deep into the core of the system to provide the protection everyone wants/needs, with minimal footprint.

There isn’t any reason you should have to uninstall the firewall, dwax, just to update your AV. If you have rules issues that are blocking the update, which you can’t seem to resolve, you can always temporarily switch the Security Level to Allow All to do the update. Or shut down the front-end of the firewall by a right-click on the systray icon and select Exit. Uninstalling each time is unnecessary insanity… :wink:

I’m pretty sure there is a list here in the forum somewhere, of registry keys to look for. Personally, I’ve never needed it. I’ve uninstalled and reinstalled this firewall numerous times through Beta testing and so forth, and I’ve never had any serious issues. Sometimes (not all times) on reinstall it tells me there’s a previous version; when that happens, I stop the process, run RegSeeker, reboot and it works just fine. Any time after making changes to the registry, you need to reboot - just in case you haven’t done so.

I’ll take a look around to see if I can find the registry keys for you.

LM

Edit: https://forums.comodo.com/faq_for_comodo_firewall/backing_up_the_defined_cpf_rules_manually-t1019.0.html;msg6358#msg6358

It could be handy : A seperate deinstallation tool that removes all leftovers in case something goes wrong :slight_smile:

Greetz, Red.

from FAQs/Threads - Read Me First

Install & Uninstall - Issues & Resolutions https://forums.comodo.com/index.php/topic,302.0.html https://forums.comodo.com/index.php/topic,1184.0.html https://forums.comodo.com/index.php/topic,5326.0.html
2nd page of the 2nd link has some info on deleting two drivers, and also manual removal of legacy keys in the registry. 3rd link, 1st post has a tool and instructions on use, to manually clear the FW out.

Bookmarked :wink: Thnx LM :slight_smile:

Greetz, Red.

Phew. I tried EVERYTHING that was described and it didn’t work.

Then I ran amok in my registry (after backing everything up, of course)… now my pc - probably out of sheer panic - agreed to let the firewall work properly. :BNC

Here’s what I did:

  • Uninstalled the firewall with its very own uninstaller.
  • Restarted.
  • Deleted each and every entry (including its folder) with “comodo” or “cpf”.
  • DELETED EVERY FOLDER (only folders!!!) THAT HAD “LEGACY” IN THE NAME!!!
  • Restarted.
  • Ran ccleaner.
  • Installed the firewall again.

As I said this was me running amok. Please, if you’re in the same situation, BACKUP your registry AND all important files before you follow my example. I didn’t care if my system would crash, I’d just reinstalled it anyway. I won’t be made responsible if you do the same and your pc doesn’t react the same way.

Again, thanks Little Mac. Maybe now you’ve got another solution to test… :smiley:

Heh. Now listen to this:
The firewall was running without trouble. Then I installed the virus scanner Avast! 4.7 (which I had on the system before, but had uninstalled as well, 'cause some Legacy folders seemed to be connected to this program, too).

And suddenly I was back at square 1, same problem as before.

Uninstalled Avast! 4.7… and now it’s working again.

Seems I’m gonna need another virus scanner… :THNK

There were some pretty intense issues with some version of Avast! HE and CPF 2.3. I have not heard of any of these occurring since CFP 2.4 came out. (and I presume there’s probably a newer version of Avast! out as well, since then - which was last fall).

When you’re looking for a different AV, just be aware that the Kaspersky-driven AVs (KAV, and AVS - the free AOL version) are apparently having a lot of trouble playing nicely with a number of firewalls. There are reports all over the web of them misbehaving, demanding the FW be uninstalled, refusing to communicate, and generally causing trouble. This is holding true with CFP as well. However, it is not the case for all users by any means; some are fine without any problems, where others can’t seem to get it resolved no matter what they do. So just FYI…

LM

PS: Thanks for the post of your crazy uninstallation and registry adventures.

LOL. No problem.

And thanks for your input about AV/FW behaviour. I’ m back with AVG now. It has worked for me before, but I wanted something better. And Avast! actually found a virus or two AVG had missed, so when this pc magazine (“PC Praxis”, issue 08/07 in German) came out and rated Comodo and Avast! so highly I figured I’d use them both.

So far, AVG and CFP are playing nicely. Let’s see what they do once I turn my back… ;D

I use Avast with Comodo Firewall with no problems at all (and SpywareBlaster and Spybot as well).

However I did have Avast installed before I installed CFP, so wonder if there is a problem with the order in which they are installed.

Mike.

MikeG, are you using Avast’s Webshield?

LM

Hi LM, just checked all the processes running in Avast…

Instant Messaging
Internet mail
Network shield
Outlook exchange (greyed out as I don’t use Outlook; use Thunderbird)
P2P shield
Standard shield
Web Shield

Hope that helps,

Mike.

P.S. I know several other people who are using Avast and BOClean with no problems. :slight_smile:

Tnx, Mike. Thought maybe if you didn’t have the webshield up, that might be the source (or part of) the problem. But looks like you’ve pretty much got it all, with no issues… Must be a computer- and/or configuration- specific issue. Gotta love those, as they are absolutely some of the most difficult to track down. If everyone has it, no problem; if a certain configuration has it, no problem. If one person has it, or two with different configurations, it becomes like that funny noise your car makes except when you take it to the shop…

LM

Exactly.
I think the problem is that there are millions of computers out there with millions of different programs installed and finding problems like that is like looking for a needle in a haystack.
All developers of software can hope for is that their products work with the majority of users. There’s always going to be a few with problems. :frowning: