"The Defense+ is not functioning properly!" Warning (First time using CIS)


I just installed CIS today and already I’ve gotten a message saying that D+ isn’t working right. I just finished cleaning this PC of all kinds of Malware and I guess I’m not too keen on Firewalls and this Defense+ thing. How can I make sure my system is protected from further attack? Firewall Security is in Safe Mode and D+ is running in Clean PC Mode. I’m really not sure what is causing this message. I’d be appreciative of any help!


Hi Xaitros & Welcome to the forums!

I would suggest you reinstall CIS and try the
latest version
again. Make sure you have no conflicting applications running in the background or on startup, Like 2 Antiviruses or other Security apps.

It’s a very rare case that people report CIS having D+ not functioning properly.


Hey Josh,

Thanks for the reply!
I’m going to try reinstalling first, but do you think AVG free or Spywareblaster running in the background would cause conflicts?
I also use Malwarebytes’ and Ad-Aware but they aren’t always active; I just use them for periodic scanning.


You’re using just the Firewall (No Comodo AV) & AVG Right?


Actually, I believe I initially had Comodo AV installed for whatever reason…
I reinstalled CIS with just the firewall and all is going well so far.
Thanks for your assistance.


AVG is full of bugs at the moment X, I don’t recommend it anymore. Do you want to uninstall it and try the Entire Suite? All you have to do is uninstall AVG, And then go to Add/Remove Programs>Run Uninstaller for CIS>Add Component “COMODO Antivirus” and reboot.

Off course, you also have other good Alternatives I recommend other then AVG if you don’t want the AV in CIS:

-Avast! Home
-Avira AntiVir

Only use one AV. Also try reinstalling CIS.


I ditched AVG 8 some four months ago because I had performance hiccups. What is the current status of performance bugs?

Happily using CIS by the way. (:NRD)(:KWL) Switched to AVIRA with CFP 3 that was lighter and then to CIS which is even lighter than AVIRA. CIS with Vista my older hardware truely rocks.

I’ve always had a problem with “The Defense+ is not functioning properly!”. I used to have Comodo Firewall Pro installed but I upgraded to CIS thinking my problem would be solved but its still there. Other security software I have installed are;

Avast Home - Antivirus
SpyBot S&D - Antispy
Threatfire - Forgot exactly what that does :slight_smile:

Does any of these conflict with CIS? I have only the firewall mode running.

I just did a fresh install of XP SP2, thinking that might resolve the issue. No luck. However, I completely removed Comodo, reinstalled it with the bottom option when choosing which level of security to install. That fixed the issue. Also, because of some of the threads out there about it, I unistalled AVG 8 and installed Avira AntiVir. Though I never really had any issues with AVG, Im definitely not getting as many popups with Avira. It and Comodo seem to blend a lot better than AVG.;

Merry Christmas everyone!
I too, am having difficulty with D+. I ran the diagnostics, and it came back “clean”, so I am not sure at this point why I get this message. This is the third time I have had this message since installing in early November.
:THNK (:SAD) (L)

Hi! I’m a new Comodo user. I installed the Comodo Firewall and Avast anti-virus. It seems to be working but I have a constant message that Defender+ is not working correctly “Defense + is not functioning correctly”. It recommends running the Diagnostic which I have done several times. It reports that all is well each time. I am running a virtually “new” installation of XP SP3 with the Windows firewall turned off. After reviewing these posts, I uninstalled CIS and then reinstalled Firewall only. The responses that I see here indicate that, perhaps, I have a “conflicting” app but no clues as to what that might be. I have the XP firewall disabled and don’t have any other anti-virus other than Avast (which many recommend running with Comodo Firewall) so I am guessing that these do coexist properly. I have MS Office and Firefox installed but haven’t had a chance to install any other utilities.

Any thoughts on what is causing this and what the impact of this warning might be??? Thanks in advance.

My guess is that it has something to do with the new installs in combination with AMD multicore (quad in my case) processors that can also cause problems with Windows XP SP 3. The new installs are the red line in the stories I read on the forum here and my situation as well, Do not know about the other users. Reinstall of Comodo after using Revo Uninstaller did not help me. Any other suggestions how to fix this? I am running Comodo on two other machines (Laptop P4, AMD 2800+) without any problem.

Hi guys,

i would also like to share my experience, this is what happened to me:

Back in october last year I installed a XP SP2, made an update right to SP3,
installed CIS 3.5.557something. All worked like a charm until today when I
noticed the tray icon of CIS had changed, ‘Defense+ is not functioning
properly’. Diagnostics did not find any problem and with no apparent reason,
no other AV, FW, anti-spy installed, for that to occur I just downloaded
a newer version of CIS - 3.5.55810.432 x32 , made a clean reinstall, working again…

Anybody any ideas what it could have triggered?

The latest CIS version is 3.8

The new version 3.8 does not fix the problem for me. What I also found is that the firewall can check for updates but fails to retrieve the update due to a communication error.

Besides not being able to update Comodo I could not get Windows updates as well! Searched the web and followed the instructions in http://support.microsoft.com/?scid=kb;en-us;943144&x=10&y=6 this Microsoft article was then able to download the updates and lo and behold Comodo works again as supposed to!

Having reinstalled CIS after a complete OS re-install I installed BOClean 4.27.
The Defense+ function in CIS now reports that it is no longer functioning properly and the diagnostic can find no error.

I read elsewhere in these forums that BOClean is to be integrated into CIS.
Has this already happened?
Am I to understand that CIS now renders BOClean redundant and that I should forego the rootkit detection of BOClean or is there a more convoluted solution to my problem?

(N.B. I also have SafeSurf, Verification Engine and CSE installed).



I feel a bit of an idiot. (Won’t say which bit.)

I ran updates on both CIS/AV and BOClean, rebooted and Hey Presto! Problem solved.

Don’t know if it will solve others’ problems but I’m happy now.


Hello there, nice to hear the problems are fixed :slight_smile:
Boclean will be part of 3.9.x releases so you can still run them together at the moment.

For this version Buffer Overflow detection is integrated in 3.8.x so i no longer use SafeSurf or Memory Firewall it’s part of CIS now.