The Defense+ is not functioning properly! [SOLVED]

I’m new here but I am not a noob to using software. I just installed XP Pro brand new to be used as a testing PC, and I am having this problem. AVG 8 Paid AV was running well along side of Comodo FW & D+


I installed 115 Windows Updates and after rebooting I am also getting this error with D+
“The Defense+ is not functioning properly!” The diagnostic utility didn’t find any problems.
I used Revo to uninstall both Comodo and AVG, I went to everywhere on my HDD and removed Comodo and AVG folders. I did a regedit for anything saying Comodo or AVG and reinstalled Comodo by itself. Still same issue.

Here is a pic of my installed programs and updates…

I just ran COMODO Registry Cleaner after another uninstall. And reinstalled Comodo FW, AV, D+ & SS.
I am still getting the issue with D+ I am flabbergasted. Can anyone help me with this issue? Thanks!

[SOLVED 1/28/2009 6:00PM]

My issues have been solved, on a hunch I decided to install SP3 for XP Pro, all is well now!!!

Here is what I did…

I installed a very old version of Comodo Firewall Pro like from 2007…

I iinstalled AVG Pro again to make sure everything was fine with those 2…

I removed Comodo Firewall Pro and AVG again with Revo…

I installed Service Pack 3>>>

I installed AVG PRO and the 1/14/2009 Version of CIS without AV…

I rebooted my PC and OMG it works!! I HATE MICROSOFT!!!

Hi. Having happily used Comodo on a number of computers for some time,I havejust installed it on a brand new laptop following installation of XP Pro. And I also get the same warning that Defense+ is not functioning properly .
Looking at the forums this problem seems to have been recurring over some period of time- has anyone found a definitive solution yet,or can someone please direct me to where the answer can be found ?
Many Thanks.

Hi guys, sorry for the trouble. I found two other threads (maybe you’ve seen them already?), but unfortunately, no real solution to the problem. - obviously you tried with CF only (after uninstalling and cleaning from CF as well as AVG) so that should eliminate the risk of conflict with other software. And martinmj, looks like you had a fresh installtion as well (what about other security software that could possibly conflict?).

Seems like reinstalling helped some users, but if that doesn’t help you guys, I honestly don’t know what could resolve the issue.


Can you please check the windows eventlog and check if there are error messages that could be related to Comodo ?

Try my solution above!

Re,Defence + is not functioning properly…was having the same problem myself after only acouple of days installation and saw that quite a few people were writing in with the same problem.I shut down my computer and a couple of hours turned it back on a nd everything is back to normal :SMLR

installed CIS on a brand new rebuild of my system. it was the first thing security software I installed after the basic setup of my computer. after about a week I noticed the warning in the tray that there was a problem. and the status indicated that Defense+ was not functioning properly. I followed the advise above and completely removed all Comodo from my system using the tools suggested and scanned the registry for anything the uninstallers may have missed. I re-installed CIS and all worked fine for a few days until the problem resurfaced.

it is possible that I have been infected with a rootkit or some trojan that is interfering with the software, but doubtful. I have run Comodo on several of my computers so I am familiar with it’s ‘quirks’ and have not seen this issue before. I am running XP pro with all current service packs and patches installed, IE-7, and Office 2007. again with all patched and service packs up to date. the other applications I have installed are the same versions that were installed in the previous build of my system which did not have this issue with CIS.

my question is - Can anyone report that the procedure posted here has permanently fixed the issue?
I do not believe that I have malware on my system based on the fact that there are numerous reports of this same problem and I doubt that all individuals reporting this issue have had their systems compromised.

If anyone can shine a light on the cause for the indication and if the posted fix is permanent it would be greatly

thanks for your help

Look up the Comodo Helper service under Services and see if it is set to start up automatically.

The same problem is boring me !


can you please tell us your history with CIS on this specific computer, is this the first clean install ?
did you upgrade from a previous version ? if so did you do a clean install did you import your old configuration etc…

UPDATE to my last whine…

I uninstalled and reinstalled with a fresh copy of CIS Ver. 3.8.64263.468. and so far I have not had a repeat of the error message. While I do not understand what generated the message in the first place, I’ll accept that the software is now installed correctly and is operating happily. nothing was changed on my system other than the install of the software. to be specific I uninstalled and reinstalled using the CIS install program and did not run any registry cleaner or other utility to weed out stray entries, files, or folders.
If things change I’ll be sure to pass it along on this thread



I updated XP SP2 to SP3 and everything is ok now.