The Defense+ is not Functioning Properly! Antivirus Error - on New Install

ISSUE: The Defense+ is not functioning Properly - diagnostics utility didnt find any problems"
ISSUE: Antivirus - Run a scan : [!] Error Code 0x80004002 No such interface supported
ISSUE: Antivirus - Update Virus Database : [!] Error Code 0x80004002 No such interface supported
RESOLUTIONS: Clean install & Registry check etc, hasnt helped resolve this.


  1. Have installed lastest version Comodo :CIS_Setup_3.5.55810.432_XP_Vista_x32
  2. Clean install - no other virus app. or firewall loaded
  3. On first step of install: Virus Checker scans computer, followed by reboot etc
  4. On reboot (standard steps, i.e: confirm that dont want professional version/upgrade etc)
    • Comodo Application opens.
  5. ISSUE: Summary Page: System Status " The Defense+ is not functioning Properly. Please run diagnostics
    ultility… etc"
  6. Have Run Diagnostics "The diagnostics utility did not find any problems with your installation.
    (have tried running diagnostics from both Summary page & also Miscellaneous, with same message)
  7. ISSUE: Antivirus - Run a scan (followed by select My Computer/Critical Areas)
    returns ERROR: [!] Error Code 0x80004002 No such interface supported
  8. ISSUE: Antivirus - Update Virus Database returns ERROR: [!] Error Code 0x80004002 No such interface
  9. Steps to try and resolve:
    • Have Uninstalled Comodo entirely - checked is latest version - and reinstalled (following cleanup steps) again.
      (already done this a couple of times … ;-(
    • Have Run Comodo Registry Cleaner

(note - i have already loaded Comodo on similar pc configuration with no issues on the other pc).

Appreciate any ideas to resolve …
I dont want to have to re-install zone alarm…


[attachment deleted by admin]

Did you delete Comodo related folders after uninstalling? Make sure to also check under Program Files\commom files\ as well as under documents and settings.

I went through all files and removed any COMODO files/folders after uninstalling.
Tried reinstall.
Still the same issue.

Any other ideas???


Pls do a virus/malware scan with an Alternative scanner.


Did it work for you doing a viruscheck with an alternative scanner?
I’ve been using AVG 8.0 Free edition and just changed to COMODO Antivirus & Firewall and got the exact same error…

Oops… I have encountered this now! In my earlier computer with XP SP2 it was working fine… But, this time my XP SP2 (another one) gives the same errors pointed out by the OP… yes… exactly the same (except that I have .477 version).

Besides 3-4 re-installs, registry cleaning using CSC, ccleaner etc., updating my directx (just a try - it was 9.0b and now changed to 9.0c), Ronny’s suggestions of copying bases.cav in safe mode and I even installed .NET framework… but in vain!

Somehow my firewall still blocks the outward connections and logs intrusion attempts… So, I am still taking the risk with only CIS Firewall (with defense+ showing not functioning status) and no antivirus (I don’t want to shift to another AV).

If this has something to do with 3.8, I hope the 3.9 version under beta testing may solve this issue.

I had been running using XP. I have used it for about a year, and though the training period was painful, I really liked the program.

The dreaded “The Defense+ is not Functioning Properly!” showed up

I uninstalled and installed 3.9.95478.509_XP_Vista_x32. I had it do a scan. The error still displays, “The Defense+ is not Functioning Properly!”

Do I have firewall protection when I see this?

Like others, I run the diagnostics as instructed, and the result is that it finds no problems with the installation. I have read the forums and see that others are having the same

I use a different virus protection, (Corporate fee but free to home users.) It has done very very well and I don’t want to change.

Configuration is set to Firewall Security

What to do!?

I think this has something to do with a corrupt SP2 or something like that. Installing XP SP3 solved my problem. My problems were similar to the opening post (Defense+ not working properly with a red circle and anti virus reporting error No. 0x80004002). Now, with SP3 CIS is back to normal.

Duck995. Please do a clean install of 3.9 without importing an old configuration. Do as follows but forget about removing the Legacy keys (they are too much work):

Uninstall CIS and reboot. Then run [url=]Comodo System Cleaner[/url] to get rid off registry keys.

Then delete the Comodo folders under Program Files, Program Files\Common Files, C:\Documents and Settings\All Users\Application Data\ .
For Vista/Win7
Users%username%\appdata\local, Users%username%\appdata\roaming\ and \Users%username%\appdata\local\virtual store

To be even more thorough open Device Manager and set it to show hidden devices under menu option View. Then see if there are Comodo driver(s) left in non Plug and Play drivers. If so select the driver → click right → uninstall and reboot.

Now delete the following:
C:\boot.ini.comodofirewall (this file may not exist).
WARNING: Do not mistakenly remove the original “boot.ini”.

a. HKEY_CURRENT_USER\Software\ComodoGroup\CFP and HKEY_CURRENT_USER\Software\ComodoGroup\Comodo Internet Security
*(If you have other Comodo products installed, delete only the values
for CFP)
c. HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services
d. HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services
e. HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\cmdHlp
f. HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\Inspect
g. HKEY_LOCAL_MACHINE\SYSTEM\ControlSet002\Services
h. HKEY_LOCAL_MACHINE\SYSTEM\ControlSet002\Services
i. HKEY_LOCAL_MACHINE\SYSTEM\ControlSet002\Services\cmdHlp
j. HKEY_LOCAL_MACHINE\SYSTEM\ControlSet002\Services\Inspect
k. KEY_LOCAL_MACHINE\SYSTEM\ControlSet003\Services
l. HKEY_LOCAL_MACHINE\SYSTEM\ControlSet003\Services
m. HKEY_LOCAL_MACHINE\SYSTEM\ControlSet003\Services\cmdHlp
n. HKEY_LOCAL_MACHINE\SYSTEM\ControlSet003\Services\Inspect
o. HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\cmdAgent
p. HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\cmdGuard
q. HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\cmdHlp
r. HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services
s. HKEY_LOCAL_MACHINE\SYSTEM\Software\Comodo\Firewall Pro
t. HKEY_USERS\S-1-5-21-1202660629-746137067-2145843811-1003\Software\ComodoGroup\CFP
kk. HKEY_CURRENT_USER\Software\Local AppWizard-Generated Applications\CFP_Setup_3.0.14.276_XP_Vista_x32
ll. HKEY_CURRENT_USER\Software\Local AppWizard-Generated Applications\CFP_Setup_3.0.14.276_XP_Vista_x64
mm. HKEY_CURRENT_USER\Software\Local AppWizard-Generated Applications\CFPLog
nn. HKEY_CURRENT_USER\Software\Local AppWizard-Generated Applications\CPFFileSubmission
oo. HKEY_LOCAL_MACHINE\SYSTEM\Software\Comodo\Firewall Pro

*Note: It may not be possible to remove these “LEGACY” keys. If you cannot delete them, leave them in the registry. However, I have subsequently found that you MAY be able to remove these keys in Safe Mode by using a third-party registry tool. To permanently remove them may also require modifying the Permissions for each key. See:;msg119226#msg119226

Now you should be good to go