That's really new: Cannot install the latest version! :-0

Hi. Previous version used before: 3.14, 4. System XP[at]SP3[at]German.

Downloaded new version, uninstalled previous, restarted, tried to install new version (AV+FW), got error messages:

Means: 1.) The folder-path “add/remove components” contains one invalid symbol/sign.
2.) CIS cannot be installed error: 1603. Serious error on installation. Do you want to retry? Yes. No.

OMG! ???

PS: Just installed previous version “cis_setup_x86.msi” dated march 24 without any problems!

Is the following of help?

i tried every method in there, i’m still having the same issue.
running on XP SP3.

i’ve tried:

  1. clean-up tool
  2. msi version
  3. update windows installer

and i still get the 1603 error.

Have u tried the .exe versions around here in the forum?

i’ve tried the exe and msi versions, both CFW and CIW. both to no avail. gave the same problem.

Thanks. I haven’t tried yet because of lack of time but I will report as soon as I know more. :wink:

I had the same issue. I found it is very easy to resolve. Just let the installer unpack the two setup files (lpcsetup_3.0.131727.7.msi and CFP_Setup.msi) then quit installer without installing. Go to the directory where the two setup files are located and install them (lpcsetup first and then CFP_Setup).

You do not need to mess around with msi-versions (for WinXP latest MSI version is 3 anyway) or registry.
The bug is in the installer, the two setup files are ok.

1.) Updating to Windows Installer 4.5 removed the error MESSAGE only but not the error, which means using cisfree_installer_x86.exe installs COMODOlivePCSupport successfully what it also did before but when it comes to click “install” (or “installing”) for CIS nothing happens anymore, installation stands still (no hang!), you can just see the installing processes when using Task-Manager in the background doing nothing but standing there.

2.) BUT when I try to install it with CIS_Setup.msi extracted by cisfree_installer_x86.exe into the “Comodo Downloader”-folder it WORKS. 88)

3.) cisfree_installer_x86.exe seems to be buggy with XP Home_SP3 even with the latest Windows installer version for XP (German system) - that’s my conclusion.

4.) Please check cisfree_installer_x86.exe for errors. :wink:

great to hear yours is fixed sterndi1.

i’ve tried your method and it still doesnt work for me.
after searching around my registry, i find that after cleaning everything (uninstalling and using the clean-up tool), there are still reminants of comodo in it.

  1. HKLM/SYSTEM/ControlSet001/Enum/Root/LEGACY_CMDAGENT
  2. HKLM/SYSTEM/ControlSet001/Enum/Root/LEGACY_CMDGUARD
  3. HKLM/SYSTEM/ControlSet001/Enum/Root/LEGACY_CMDHLP
  4. HKLM/SYSTEM/ControlSet001/Enum/Root/LEGACY_INSPECT
  5. HKLM/SYSTEM/ControlSet002/Enum/Root/LEGACY_CLPSLS
  6. HKLM/SYSTEM/ControlSet002/Enum/Root/LEGACY_CMDAGENT
  7. HKLM/SYSTEM/ControlSet002/Enum/Root/LEGACY_CMDHLP
  8. HKLM/SYSTEM/ControlSet002/Enum/Root/LEGACY_INSPECT
  9. HKLM/SYSTEM/CurrentControlSet/Enum/Root/LEGACY_CMDAGENT
  10. HKLM/SYSTEM/CurrentControlSet/Enum/Root/LEGACY_CMDGUARD
  11. HKLM/SYSTEM/CurrentControlSet/Enum/Root/LEGACY_CMDHLP
  12. HKLM/SYSTEM/CurrentControlSet/Enum/Root/LEGACY_INSPECT

i cant seem to delete these values. could these be stopping CIS from installing?
CIS3.9 installs fine on my comp, but CIS4 stops when registering values, then it rolls back action.
Please help!

CIS 3.9? I don’t remember there was such a version. before 4.0 there was 3.14 installed on my system.

Take a look at the release notes on for CIS:

Reading this I wonder where to put CIS 3.9 and why it’s not listed there. ???

Anyway: These registry valuses actually shouldn’t hinder installing CIS after restart after deletion! You MUST restart if COMODO (or the system) advices to do. Check also your installer version by Start>run>msiexec /? ok and see if it’s really 4.5 which is the latest for XP.

Anyway - you can delete those values - I did it already when trying to resolve the installation problem: You must rightlick on the registry entry go to the field - and now I don’t know how microsoft calls “Berechtigungen”, must be sth like “rights, allowance, authority or permission” - Then you see a window with “SYSTEM” and another entry like “all, everyone, each or so”, give this “all” complete permission and you can delete those values easily. Just try. Also delete all COMODO entries on your HDD guessing you’ve done already. :wink:

I have the same problem. I did everything recommended on this page. No result. It installs everything, later roll backs all, and error!
Using XP with SP3

The questions to COMODO:

1.) What’s wrong with cisfree_installer_x86.exe, the main installer of the new CIS-Version?

2.) Why does Windows Installer 3.1 included in XP_SP3 cannot handle latest CIS (or the other way round)?

3.) Even if latest CIS version REALLY requires Windows Installer 4.5 why isn’t it included in CIS 4.0 as REDIST-files or why doesn’t CIS 4.0 inform during installation that Windows Installer 4.5 is required such as other programs do?

4.) Finally: Why there are STILL problems AFTER installing Windows Installer 4.5? :stuck_out_tongue:

[at]everyone with XP AND problems with the latest CIS 4.0 version:

Better to install CIS 3.14 or a CIS 4.0 version before “4.0.141842.828: 12 April, 2010” until the problem is resolved - always keep the last running older vesion of CIS on your HDD for a re-installation. :wink:

Update!: I just tried to install latest CIS 4.0 on a test system with XP_SP2_Win Installer vers. 3.0!

Results: “cisfree_installer_x86.exe” didn’t work as known already. CIS_setup.msi installed fine even with “old” Win Installer 3.0… so? :wink: It’s up to COMODO to check this behaviour - my test system is a clean XP_SP2_Prof. :slight_smile:


I got the same nasty issues other users reported while installing v4.xx - error 1603; funny thing is also on version dated back 24th March I am unable to install as the system says there has been an issue during installation (from progress bar I can say during kernel drivers installation if can be of any help).

Tried the most frequent easy things like re-download file, reboots, install of Win installer 4.5.

Nothing seems to work on any v4.xx while I managed to succesfully install and run v3.14 on my pc.

Note: I was having another internet security from another vendor, I run XP SP3.

Anyone’s able to tell me how to sort that out?

Any help will be welcomed, thanks!!

What I saw there’s a Web installer as well to be chosen - it’s worth a trial but I have no experience with it.

Have you tried to install directly from the unpacked xx.msi AFTER starting the main installer and chosing what you’d like to have installed? Instead of starting the installation unsuccessfully again quit installation and go to the folder in C>docs and settings/all users/application data (or similar :wink: - hidden folder!)>Comodo downloader.

In this jungle of words you may not have read that this method worked for me. But it’s remarkable that it hasn’t worked with version “4.0-March 24” for you because THAT main-installer didn’t cause errors on my system… :o


I didn’t try your suggestion to be fair but I did try the internet installer and got the same negative result.

Now that I have 3.14 installed I think I will keep it as reading some further posts this build is appa
rently better than the new v4.xx which is reported to be a bit “immature” - not sure about this though and have to say I am totally new to Comodo and not an IT security expert at all :wink:

In summary I am thinking to stick to v31.4 and wait 'till I will be able to upgrade it through system’s updater (well, guessing this will be possible in the future…)…hope that’s a good choice!? >:-D

I didn't try your suggestion to be fair

No problem but why? :wink: I am new as well and startet with 3.14. ;D But if you fell better with 3.14 it’s ok - it’s part of my suggestions if one doesn’t like 4.0 for whatever reason.

I just hope COMODO will fix this XP-installer-bug. :-TU

Not sure if there’ll be an internal program updater from version 3 to 4 in the future…

I finally tried with your procedure as well…but same poor result as per previous versions to the last one: no error 1603 but still while installing kernel drivers system rolls back and installation fails…I’d say issue should be on my PC but cannot say where!!!


OMG… ??? Last suggestion - uninstall>restart>search for comodo in windows search and delete manually. Search for comodo in registry with a registry finder which is easier than in regedit. :wink: Do you have other Comodo programs installed? Then I would recommend to uninstall all of them for the moment.

In the registry there may be some files which cannot be deleted - you can by changing the permission directly in the registry. Be careful not to delete something wrong there - only COMODO entries and nothing else.

Also go so start>run>%tmp%>ok and delete what’s possible in this folder. Files cannot be deleted are just in use. It’s just the user-temp-folder which frequently should be emptied.

Restart and make a last try - otherwise keep 3.14 which isn’t bad at all.

when uninstalling I recommend using revo uninstaller set to moderate to find left overs, delete everything it finds and then restart, not when comodo uninstaller asks you to restart.

I could even unistall everything and search for traces in the registry…but when I uninstalled previous Internet Security system (I used Kaspersky) and tried first install with v4.xx I had the “infamous” error 1603…so wouldn’t think this is the issue…or am I wrong?