Terraria Hosting Issues

Hey all. Its been a while since i posted with a problem about comodo internet security, but here we go.

So I’ve been playing Terraria recently and when I host a game other players cannot connect. I have set all Terraria files as “Allowed Applications” and added them to the “Trusted Files” list. But people still cant connect, and nothing even shows up in the log as being blocked.

I know it is Comodo firewall that is causing this issue as when I uninstall CIS I dont experience this issue.

I still experience the problems when I disable the CIS firwall. The problem only stops when CIS is uninstalled.
I have also disabled the firewall on my router and placed my computer in the DMZ but when CIS is installed I cannot host games.

This guy has reported the same issues: http://www.terrariaonline.com/threads/no-one-can-join-my-server-checked-everything.73635/

He mentions something to do with the way CIS hook works but I dont know if that is what is causing the issue. Please help.

You also need to make a matching Global Rule to allow incoming traffic for the port(s) that are used for the incoming traffic. Incoming rraffic always goes through Global Rules first before going through Application Rules.

Thanks for your help, with this information I have identified that the global rule causing my problems is:

BLOCK, IP, IN, Source Address: ANY, Destination Address: ANY, IP Protocol: ANY

Unfortunately I don’t know how I can add a rule that will exclude a single port (in this case 7777) and not be overridden by the rule above.

If you could inform me on how to proceed I would be most grateful.

Read the following tutorial I made. Substitute the port numbers and protocol for your situation.

To open the port TCP 1723 for example

First step is to determine the MAC or Physical address of you network connector. Go to Start → Run → cmd → enter → a black box will show up and enter the following → ipconfig /all (notice the space before /all) → enter → now look up the Physical address and write it down.

Notice that Physical address = MAC address

Advanced Settings → Firewall → Global Rules → Right click → Add → fill in the following:
Action: Allow
Protocol: TCP
Direction: In
Description: Incoming Port

Source address: Any
Destination Address: Choose MAC address and fill in the found MAC/Physical address
Source Port: Any
Destination Port: 1723

Now OK your way back.

thanks I will give that a try and post back with my results :stuck_out_tongue:

Yes All working, Good Job Comodo Forums xD

Glad it worked out for you. :slight_smile:

I have a similar issue and have tried to apply the instructions (tutorial) but unsuccessfully? Any thoughts or more specific advice. I have been running this application successfully on an older version of comodo and windows 7 without changing any settings from default. I may have just accepted the activity when and if comodo sent a warning before proceeding. No such warning is happening now?
Now I am running the latest comodo and windows 8.1, something has changed but I am unable to find that change?
Any suggestions?

Can you post a screenshot of the Global Rules you have? Did you give Terraria the Allowed Application policy?

pdf attached.
Not sure which screen you would like to see?
allowed terraria server application, exactly the same as the working older version, “custom” setup, I am assuming Comodo set this up when I accepted the application initially. the custom rule is…
“allow IP In From MAC Any to MAC Any Where Protocol is Any”

[attachment deleted by admin]

Your Application Rule seems fine.

What did you fill in with the “Incoming Port” rule in Global Rules under Source and Destination Address? Try Any for both and see if that makes a difference.

All my settings seem consistent with what’s required and what has worked previously …I have also tested the application by turning both the comodo and windows 8.1 firewalls off with no effect…the application still works through the router using an older PC running XP and trend micro and a laptop running comodo and Windows 7 so I’ve moved my attention to the “Steam” software environment unless you have any other suggestions? Much thanks anyway…

With the problem still happening with Comodo and Windows Firewall disabled I am starting to think it may be a problem related to Windows 8.1.

I assume the programs does not get sandboxed. Is that a correct assumption? Have you had any other security programs installed on your Windows 8.1? Is there another security program running in the background alongside CIS?

Eric, an update on progress, not sandboxing, no other scanner running eg McAfee is a common one that gets on with other applications.
Working on a PC and a laptop concurrently with identical setup. The PC is now working, but can’t say which change fixed it, however just before it started working the Windows firewall ask for clearance to connect.
Now the laptop, made identical changes to Comodo and the windows firewall but to no avail? Interesting that pinging the laptop machine is only successful with both firewalls ate off, both individually prevent a Ping response…one PC down one laptop to go…