Temporarily Disabling Comodo Firewall

I tried to access a specific site this morning and was completely blocked from it. Comodo Firewall will usually give me a warning that a site is “unsafe” for various reasons and then the option of continuing to the site or not. Not this time. The site is completely blocked. The reason given was “Site may contain excessive advertising including pop-up or pop-under advertising”.

How do I temporarily disable Comodo Firewall or configure it to allow me access to the site?

This is a function of SecureDNS, not the firewall. Disabling the firewall won’t allow you to access the site.

If there is no link to go to the site anyway, your only option would be to use a proxy, or changing your DNS servers back to whatever you were using before SecureDNS.

You should be able to access the web site you want. The button is there at the alert page.