telnet delay then lose connection

OS: windows 8.1
NO other anti-virus softwares
COMODO v7 (latest version, and install firewall only)
Application: windows’ telnet client (C:\Windows\System32\telnet.exe )

The connection of telnet seems fine, but is blocked if no any keyboard operation within almost 20 seconds and then lose connection. If the firewall is disabled, no blocking happens.
If I disable the firewall just when telnet is blocked (but not lose connection yet), telnet is unblocked right away.

by using the function “View Connections” of COMODO, I find something weird.
The process of telnet will disappear just the same time when it is blocked.
There is no reason that the process of telnet disappear because the window of telnet is still open and the Windows task manager could also find this process.
I find someone talking about the delay/buffer of the input character of telnet:;msg391393#msg391393
I strongly recommend your engineer to check how the exception is handled when the buffering of input character of telnet/ssh makes error.

BTW, my settings:
HIPS ON (tried), HIPS OFF (tried also)
Sandbox OFF
Advanced options of firewall: all checked (tried), all unchecked (tried also)
Allow telnet connection from any resource to any destination for any protocol.
Others are default.

View Connections is not a process manager, it only shows processes with an open connection. So if a connection closes, and no new connections are made, there’s no point in viewing processes with no connections under ‘view connections’.

Try updating to the just released 2142. That may bring a solution.

Another weird thing is the telnet process will still disappear in ‘View Connections’ when the COMODO firewall is DISABLED.
(telnet won’t be blocked but keep connecting to internet.)
As you say, ‘View Connections’ shows processes with an open connection. But actually it lose the monitoring of telnet.

Thanks for your information. (I couldn’t find 2142. Did you mean 4142 on 17 April?
see the release page: Comodo Internet Security Release Notes

Fixed Alerts are blocked while there pending notifications – This may cause some users to observe blocked Internet, delayed alerts or sometimes freezes.
Yes! I think they fix the problem. Glad to see my telnet not dead (yet).

Hi mochidawn,
A small typo on Eric’s side. :wink:

Latest release found in the link below.
COMODO Internet Security 7.0.317799.4142 Released!

Kind regards.

Thanks for your link. I’ve installed 4132 and then updated it to 4142. (took a little bit long while…)

Blocking is back today.
But in the past one week, it worked good.
I didn’t install any other software during this period.
Today, as usual, I still opened Chrome and telnet, and then found telnet blocked again.

Did you have other security programs installed in the past? If so run clean up tools for them just to be sure all of their components are removed. A list with such tools can be found here: ESET Knowledgebase .

Can you see if that makes a difference or not?