TC Server Problems

Any update on the problem?

I haven’t been able to get any response from TC servers for about 5 days or so. No error messages or anything, I plain just can’t connect. I checked out the lastest .conf file, and neither or the raw IP address is working.

EDIT - ok, I’d still like an update…but there’s a chance my work might be blocking this connection. I’ll need some info from the TC guys to be sure.


We haven’t have any problem with TC access server ( Problems with one of accounts management server.
We are sorry. The problem will be solved asap.

Ah, ok. I couldn’t connect from home either, so that would explain it. I can ping the server from home, but get auth failed messages. I’m guessing they block PING at work. I also have to go through an http proxy at work, which I think was disguising the auth failed messages, or timing out or something.

Glad to hear it’s being worked on. So it would be safe to assume then this does not affect all accounts?

I signed up for this beta several months ago. It worked beautifully for an extended time, and now it has crashed. Frankly, I don’t see a sense of urgency from the wonderful folks at Comodo about getting TrustConnect off the floor, and running again.

If this is a viable initiative (and possibly one that can generate revenues and profit for Comodo, as suggested earlier by Melih), then please put adequate resources behind this program, fix it, and roll out your business model.

On the other hand, if you have second thoughts about the viability of this, or don’t have the resources to fix it, that’s OK too. Just communicate - let your user community know that is a dead-end project; so those of us who use VPN encryption can seek other alternatives.

No hard feelings !
Thank you.

Trust Connect service is working now.

Problems of Trust Connect service were solved.

Excellent news! Thanks for the updates and the resolution. I’m up and running once again. Thanks!

I can also confirm that TC is online and working fine! Thanks! :BNC

I am connected!