Tabs bug with CID 20.0.1.12 [merged]

I’m not sure if I’m the only one affected; everyone must being using CID with the tabs on top.

What happens is that the back & forward arrows to the left of the address bar disappear into the black background if the tabs are below the address bar. This was not happening in previous releases of CID.

[attachment deleted by admin]

Just download version 20.0.1.14. When I move the tabs from the top to under the address bar, the forward/backward arrows disappear and are scrambled. Whatever you want to call it, it looks like ■■■■.

WinXP
Eset Antivirus v.6

[attachment deleted by admin]

I can confirm this bug, also have had since last couple updates, turning off hardware acceleration doesn’t fix, have disabled all plugins and extensions, also done clean re-installs, but still have buttons greyed out.

  • Your Operating System (and whether it’s 32bit/64bit);
    Windows 7 64bit

  • Security Software Installed;
    Comodo Internet Security 6.1.276867.2813, the full suite.

  • How you produced the problem;
    Just launch IceDragon like normal.

  • How you tried to resolve the problem;
    I have disabled all plugins and extensions, also done clean re-installs.

  • Screen-shots with the error (if any);
    Attached to this post.

  • Post Memory Dumps on crash if you encounter any;
    N/A

  • Any other Additional Information;
    I’am using the default IceDragon skin, with menu enabled.
    I have EMET 3.5 protecting IceDragon and plugin-container using only DEP protection.

[attachment deleted by admin]

I have created a second profile using --profilemanager switch and now IceDragon buttons are back to normal, have configured options and installed all my extensions again in this profile and all still working normally, so have to conclude something has got messed up with the default profile.

I would suggest the OP creates a new profile to see if this fixes the issue like it has for me :slight_smile:

Attached screen shot of second profile running correctly now :slight_smile:

Edit: Just noticed in OP and mine how both our messed up buttons screenshots have tabs below, but in my new profile the tabs are above, if this where issue is ??

[attachment deleted by admin]

I have tested IceDragon with tabs on top vs tabs on bottom, can confirm now that setting tabs to be on bottom causes the buttons to become greyed out and look messed up, have attached a couple screenshots to show this :slight_smile:

Can someone test this issue out, looks like a bug in the theme when having the tabs configured to be on the bottom!

[attachment deleted by admin]

While I have not the same bug I’m experiencing similar UI bugs with CID, like this one.

http://i40.tinypic.com/xojm0i.png

  • Your Operating System (and whether it’s 32bit/64bit);
    Windows XP Professional SP3 32 bits

  • Security Software Installed;
    AVG Free Anti-Virus Free Edition 2013

  • How you produced the problem;
    Installed the Feedly add-on in Comodo IceDragon from here [direct download]. However, it was not the first time this bug appeared. It happened with others add-ons that include an icon at the browser’s tool bar. So, it’s an GUI bug related thing rather than an add-on related.

  • How you tried to resolve the problem;
    Not tried actually. Disabling the add-on, I guess.

  • Screen-shots with the error (if any);
    Yes, it’s above

  • Post Memory Dumps on crash if you encounter any;
    N.A.

  • Any other Additional Information;
    N.A.

Best regards,

Yes.

I think they know it all.
I hope that will fix in the next version.
Thank you.

[attachment deleted by admin]

Now I found one topic “Office Black” and checked.
See the screenshot. Everything is working.

But I also think that there is a bug.

IceDragon 20.0.1.14 Portable.

P.S. Here’s another topic: 2 screenshot.

[attachment deleted by admin]

I really hope so, I have got so used to using IceDragon that its made Firefox even less comfortable to use ;D

Thank you jenny66 for your post :-TU

Question for jenny66 in reference to the “Office Black” screenshot: If you change to tabs below the address bar, do the back/forward arrows disappear?

Do you mean that when you work with bookmarks button forward / reverse does not work for?
Everything is working. If it is redirected to another site, it opens in a new tab. But if all the links on one site then the button forward / reverse - active.

Do you have it is in mind?
During the transition to bookmarks, forward \ back - to working.

P.S. Lost only native icon - Download. (When working with it).
Restored only after restarting the browser.

This addition I do not use. I gave you an example of.

[attachment deleted by admin]

No, that is not it. What I was hoping you would do is go into your ‘about:config’ file and set the value for ‘browser.tabs.onTop’ to ‘false’ so the address bar would be above the browser tabs and see if the back/forward arrows to the left of the address bar disappear when you do this.

The arrows still work, they just disappear when you have the address bar above the browser tabs.

Thanks!

I understand now. No. Do not disappear.
It is with: “browser.tabs.onTop” “false”

Edit: As long as you do not click on a new tab, the arrows are not active.
If that.

[attachment deleted by admin]

Thanks jenny66. That answers my question. This would help someone who prefers to have the address bar above the tabs to do like you did and replace the default theme with a different theme.

There is also another Topic: Forward/Backward Arrows Bug started by Vardog that has this same problem with the disappearing arrows.