System Restore

Win 7 64

Today I did a system restore & selected a restore point created on 15 Jan 2013. After system restore CIS tried downloading the full AV databases again. The scanners folder had the databases till 17 Jan 2013 but the about screen showed databases version 1. I stopped the updates & cut the databases from the scanners folder & pasted on desktop & imported the databases & this worked.

Is this a bug?

I personally do not think of it as a bug.
I imagine the update mechanism of CIS gets set back to the restore date and presumes it has not been updated for two days.

If the DB has not been updated for an est 48hours it will download a full Database, by design.
My guess for the reason for this behaviour, is a way to reset itself in case of Database corruption being the cause of the update delay.

Diagnostics didn’t find anything.

48 hours is too less to download the full databases. Atleast a week or 10 days later it should download the full databases.

Maybe something for the wishlist, make the time frame configurable?


Please note, my statement above is only from personal experience and what happens on my systems, I assume it is by design.
I have seen no official documentation about this and I apologize if my statement was misleading.
Thank you.

It looks like CIS noticed an error with the av database that made it redownload the latest available full database and incrementals. I don’t know if this is a bug as I don’t know if with v6 the registry gets involved with keeping track of the status of the av database; with v5.x CIS just would look at the bases.cav file.

On a side note. The latest available full database gets updated every two days:

The complete Comodo Internet Security database is available for download. This is useful for those users that wish to manually replace the existing database or would like access to the database for other reasons. The complete, downloadable database is updated approximately every 2 days so may not contain all the latest definitions as shown in the table above.
Source: Comodo Anti Malware Database Latest Version & Additions 2022 .

I don’t think that means CIS will redownload the full database every two days.

System restore sucks, just download COmodo Back Up put your info in a partition, order it by subfolders and make a 1 weekly and 7 daily back ups, delete weekly back ups as you see fit, maybe COmodo Back Up can help you with that.

Today I check my CIS scanners folder. And I noticed there were 2 databases instead of 1. One was till the date the above mentioned happened & the other was the latest.

I had cut the databases from the scanners folders & pasted on dekstop & then imported again. I dont know how 2 databases were there in the folder.

Anyway I reinstalled CIS & imported the databases & everything is fine now.

One would have been an obsolete/outdated DB file left behind from System restore.
You could have simply deleted the inactive DB file.
If you tried to delete the active/open file you would have been notified that it is open and deletion would fail.

After system restore I had removed the DB left behind & imported again then too 2 DB appeared.

I thought of deleting the databases but then decided to reinstall.

By the way I tried system restore again, though the previous was 2 days back this one was 30 mins back, & after system restore this time there was no such prob.