System Restore\ Windows 7 \CIS

In all the time that i have been running Windows 7 RC with CIS i have not been able to successfully use system restore each time the report says the files were unchanged.
I am just wondering if CIS was causing the problem because i can’t think of any other reason,
If anybody has an opinion on the subject please let me know.

I had windows xp and the same thing happened with Comodo firewall pro installed.

My XP computer is not affected,At least i don’t think so
Thanks for your interest

For all interested party’s
The problem is CIS.
I disabled all aspects of CIS and then did a system restore the result was that System Restore worked perfectly.
Lets hope it gets fixed in the next version.

Well, that’s good, not bad, but You do not realize it.:))It means CIS protects Your PC perfectly.What’s the problem with disabling components and doing system restore with disabled FW or AV or D+ ? I really don’t understand.

None just the convenience.

This was happening to me also on my vista machine and now my windows 7 machine, both 64bit.

Disable Antivirus,Firewall and Defense +
This can be done,assuming you don’t how,right click on the icon by the clock and you will see all applications.
Click on each one in turn and change setting to disable.
Run System Restore.When your computer reboots the settings will be returned to default.


My pleasure

I tried System Restore again this Morning.It didn’t work.
So my suggestions are of no use.
Does anybody have any ideas

This has nothing to do with CIS. CIS is OK.
CIS doesn’t mess with Restore Points in this way.

Take a look at the links above. Might workaround your issue.

System Restore Points - Stop XP Dual Boot Delete | Vista Forums (follow the MANUAL “fix” in this first link) (for general help)

Good luck!

edit: 1) MS link for this workaround

    2) activating BitLocker on Vista/W7 Ultimate/Enterprise seems good too:  might help on this without TPM .

Not really applicable.
The problem is not restore points.There are lots of those.The problem is,as i said in my first post,system restore does not restore to an earlier time.That is the files are unchanged.
It could be a bug in W7 RC that is corrected in the final version.
I will find out when i install the finished version.


Firstly i tried to run system restore with my computer running normally.Here is the message i got when it had finished.
“System Restore did not complete successfully.Your computer’s system files and settings were not changed”
"System Restore failed to extract the file (C:\Windows\system32\drivers\sfi.dat) from the restore point.
An unspecified error occurred during System Restore.(O x 80070005) "
“You can try System Restore again choose a different restore point” etc,etc,etc.
I then tried to run System Restore in Safe Mode and it completed successfully.
I then again ran System Restore and used a different restore point and with the computer running normally.I got the same error message.
I then uninstalled CIS,rebooted,and ran System Resore again.It completed successfully

More later.
Stay tuned

Re: C:\Windows\system32\drivers\sfi.dat

From OmeletGuy:

“This file is where CAV’s keeps a list of clean files it has scanned before, until a AV update then it resets the file. (Stateful File Inspection).”

Unfortunately, this file is locked by the CIS AV and cannot be accessed. The only workaround is to not install the AV.

Interesting point for which i thank you.
I am in touch with the company regarding the problem.At the moment they don’t have a fix but are working on it,thay say.
I will post here when they come back to me.
At the moment,as a work around,they suggested running System Restore in safe mode.
In the meantime i am using a different AV until they come up with a fix,
Thanks again for your interest.

This problem definitely does affect XP machines as well. I have turned off system restore since it’s now useless. I have never had to use it anyway but when I tested it I got the same results as given in this thread. It doesn’t work. This is a serious flaw that I’m shocked has not been fixed yet.

I have not yet had a reply from Comodo.The last they said was that they are still working on fix,
In the meantime i have uninstalled the AV and installled Avira in it’s place.
Result–Problem fixed.“System Restore” works perfectly

As a workaround under Vista and Win 7 you can boot from the installation DVD and start System Restore from there. That works without a glitch.