System crashes after last update


I’ve been using the free verion of firewall.
After last update something strange began to happen. After 15-60 minutes from boot up my computer was starting to freeze. First OS’s windows started to freeze but everything else was ok. A moments later everything was in freeze but mouse cursor and sounds were intact. Could move my mouse and music was still being played. Unfortunately there was no response from anything else. Had to hard reset my pc. It has happened several times.

I blame firewall because:

  • its update was the only change in software for about a week
  • problems started minutes after update
  • firewall was reporting tenths (50-150) of incoming/outgoing connections for svhost and Avast anti virus software
  • clumsy removal of firewall helped

Removal was problematic… Normal uninstal was impossible - system reported some error with windows installer which couldnt be initialized for comodo’s firewall. I had to boot up my pc in safe mode and manually delete the content of comodo folder in program files. One dll file is still there - wasn’t able to determine which service/process is using it to terminate it and remove file. I cleaned my registry and there seems to be no trace of firewall left. The file is still impossible to move.

I’d like to resume using of comodo’s firewall. One of the best pieces of software I’ve ever used but I’m affraid that the problem may return. Internal installation checker of the firewall didnt report any problems. And my uninstallation was also very problematic and a lot of debriss must have stayed for sure.

Is this a known problem? Did anyone have it too? How to properly recognize and fix it? Can I safely reinstall the firewall? What should I do before reinstallation?

I’m using Windows 7 x86 Ultimate. System is frequently updated. I’m also using the latest Avast free anti virus software.

I will be extremely grateful for any help!!! I just want my firewall back… :frowning:

Please run this clean up tool, reboot and try installing again.

Let us know how things go.

What I did:

  1. Downloaded the zip file containing cleaner;
  2. Extracted on my desktop;
  3. Created a system restore point;
  4. Ran the cleaner using “run as admin”;
  5. Got either “access denied” reports or file/reg entry not found msgs, also some services were stopped.
  6. Reboot;
  7. Internet connection was broken. Run the cleaner again as it was recommended. Same results.
    8 ) Reboot;
  8. Files still present. Unable to connect to the internet. Unknown problem.
  9. Tried to restore system to the restore point created in point 3)
  10. Black screen after loggin in. Unable to start explorer service. System froze but I was able to ctrl+alt+del it. Logged off;
  11. Reboot in safe mode;
  12. Restored to a previous than point’s 3) restore point (made before some system update);
  13. System working again.

The cleaner has done nothing besides funking up my internet connection. Also Windows Action Center (dunno if it’s the right translation - it’s a white flag in system tray nagging about security issues etc.) was turned off and I was unable to turn it on again.

Situation now: same as in the 1st post. Junk files are still present.

My connection speed is at 5% of what it should be. It’s probable that it’s my ISP’s fault but it is far more likely that some firewall’s leftovers are interfering with my connection. Is there maybe a list of services/processes I could manually disable or disable it’s automatic start at system startup?

You are describing the situation where internet is not working after cleaning and reboot. That’s the situation where the firewall driver is still present. Read the following on how handle that situation.

How to uninstall the CIS firewall driver when it stays present after following this or using the clean up tool? Look up the properties of the network connection, select the Comodo Firewall driver and uninstall it. See the attached image.

Now reboot back into Windows and CIS should be gone and you should be able to install it again. You can run a couple of registry cleaners you trust to see if there any Comodo left overs.

Now you should be good to go.

Next step in making a level playing field for installation is to remove any left overs of previously installed security programs.

We are gonna take a look to see if there are some old drivers of your previously uninstalled security programs are still around. Go to Device Manager → View → show hidden devices → now look under Non Plug and Play drivers → when you see a driver that belongs to your previous security programs click right → uninstall —> reboot your computer.

When the problem persists make sure there are no auto starts from your previous security programs. Download Autoruns and run it.

This program finds about all auto starts in Windows. This tool can therefore seriously damage Windows when not handled properly. After starting push Escape and go to Options and choose to hide Windows and Microsoft entries, to include empty locations and then push F5 to refresh.

Now check all entries to see if there are references to your previous security program. When you find them untick them. After unticking reboot your computer and see what happens.

The driver was already gone. Did not have to uninstall it - I must have succeeded in my 1st attempt to do that particular thing.

The autorun software was extremely helpful. I was able to remove several comodo related entries. Unfortunately there is still one left:
Comodo Antivirus (no description)
It’s listed twice in 2 different sections. It’s disabled but I am not able to delete it - error is returned saying that a file named cavshell.dll is missing.

I’ve also deleted one Comodo related entry from deviece manager → non p&p drivers

This piece of software is great! I’ve found some useless buttsecksware trying to update non existing for long time software O0

I’ve managed to remove that Comodo Antivirus entries. Should I use the cleaner again now or we are good and I can reinstall firewall?

Just to be on the safe side I would say run the cleaner and then try installing again.

I ran the cleaner but all I got was file/entry not find or access denied errors. I decided to run it in system’s safe mode. Everything went smooth this time but after reboot windows’ action center reported that I have no antivirus installed. Avast was still present and working but was not recognized by system. I reinstalled it. Then I installed comodo’s firewall.

Everything seems to be working ok now. I just need to figure out which settings were I using. I was getting way more wanted security alerts about various processes on my pc before all these problems o)

Thank you very much for your help, EricJH! You are my personal firewall hero :-TU