svchost listening on port 135 but Comodo doesn't show it

When using a scan by the report shows:

“Process svchost.exe (1012) listens on ports: 135 (RPC)”

Why doesn’t Comodo show this when viewing “Active Connections”? Instead, Comodo shows that “System” is listening on port 445, which, on the other hand, is something BitDefender’s log does NOT show.

I have also disabled NetBIOS over TCP/IP, which I understood was related to port 135 but svchost still listens on it. Should/can I somehow make sure that this port is blocked through Comodo? I already have used “Block all incoming connections” option from “Stealth Ports Wizard.”

This post;msg476361#msg476361 will help you.

Thanks, that was helpful.

Rather than make a new topic, however, I’d like to ask you something:

When using ShieldsUp! firewall test, I do a port scan and it gives a status of ‘Stealth’, passes Solicited TCP Packets and Unsolicited Packets test, but fails the ping test by receiving it.

Is this something to worry over, and what can I do to make Comodo block the ping request? I kind of thought CIS would have done this by default when choosing to Stealth all ports and block incoming connections… I am behind a router, by the way.

Thank you.

The port scan is testing the router then, and not Comodo Firewall. For the port scan to check the Comdo Firewall you’d have to enable the DMZ functions of your router with your PC’s IP, then do the port scan.

Thanks for the tip, but my router does not have its own firewall, there are no ports closed nor does my ISP block/redirect traffic on any ports, so can the router still interfere with the port scan?

A router is a hardware firewall, as it’s purpose is to do NAT. So yes it is still affecting it, useless you enable DMZ.

I see. Then it appears that the people who provided the router (my ISP) do not have much information on it, as I called them and they directly told me the router is not protected/firewalled. When accessing it from my computer there are very little settings to mess with, only a “Tuner control”, an option to switch either between routed or bridged mode, and turn Wifi on or off. It does not even ask for login information.

Any idea how I could enable DMZ on it? Or perhaps it is simply not possible on this type of router?