-> router crash [?]

This is what happened today when I tried to visit to download some drivers.

My router crashed!

I had to restart all my network services from my PC and do a network troubleshooting in Windows.

You can test to confirm… I don’t know what’s going on really…

Proceed with caution.

No problem here for which is what I get from h**p://


update: i finally figured it out… it was a false alarm.

Windows 10 decided in its politeness and user care to automatically install an updated driver of my network card… this broke my internet connection… Yay windows 10 !!!

Now i am back on track after a reinstall… quite a pleasant way of spending an afternoon… Thank you windows 10 for your automatic driver update bullcrap once again.

Yup, it’s amazing, and the setting to disable driver updates doesn’t work. Windows 88)

Navigate to System and Security > System > Advanced system settings. Click the Hardware tab, click Device Installation Settings, and select the “No, let me choose what to do option. Select “Never install driver software from Windows Update.” This works as far as I can tell.

Also there is a troubleshooting tool to hide updates → Windows Update: FAQ - Microsoft Support

That setting does nothing for me, it will still find and try to install driver updates, some even completely irrelevant to my system. I’ve had the use that tool several times now for at least 3 different drivers.