Summary says "1 unrecognized file", but there's 0 in unrecognised files [299]

The gist: On the main screen (Summary tab), in the D+ module where it shows “unrecognized file(s) observed”, it says there’s 1 file… yet when I actually go into the Unrecognized Files box there is nothing there.

The bug/issue

  1. What you did: Removed a file from the Unrecognized Files box.
  2. What actually happened or you actually saw: After removing the number (1) was still there on the Summary tab, although the file is no longer in the box.
  3. What you expected to happen or see: To see the number go to “0” after removing the files, as it had every other time.
  4. How you tried to fix it & what happened: I’ve tried deleting/purging even though nothing is there, disabling then re-enabling both the Sandbox & Defense+, disk cleanup utilities (CCleaner & CSC)/rebooting. None of it has worked.
  5. Details (exact version) of any software involved with download link: Does not apply
  6. Any other information (eg your guess regarding the cause, with reasons): I notice that after removing files from the box it takes several seconds until the change is reflected on the Summary tab. I was thinking that perhaps I closed out the screen too fast and the change didn’t stick. I haven’t had any pending files since to test this theory though.

Files appended

  1. Screenshots illustrating the bug: Attached
  2. Screenshots of related event logs or the active processes list:
  3. A CIS config report or file.
  4. Crash or freeze dump file:

Your set-up

  1. CIS version, AV database version & configuration used: Comodo Firewall with D+ v.5.0.162636.1135, Avira Antivir Personal v.10.0.0.567
  2. Whether you imported a configuration, if so from what version: Does not apply
  3. Defense+ and Sandbox OR Firewall security level: Firewall - Custom Policy, D+ - Safe Mode, Sandbox Enabled, all boxes checked, treat unrecognized files as Partially Limited.
  4. OS version, service pack, no of bits, UAC setting, & account type: XP Pro SP3, 32 bit, was using Admin. acct. when problem occurred.
  5. Other security and utility software running: Nothing else real-time
  6. Virtual machine used (Please do NOT use Virtual box): Does not apply

[attachment deleted by admin]

I have this same bug.

Thanks that makes it clear. I think the answer maybe in the words ‘so far’ in the summary.

This is a cumulative total. So my guess is that there was a file in unrecognised files, and you made it trusted. That means that there are zero currently in unrecognised files, but it’s still true that 1 has been blocked ‘so far’

Does this make sense to you?

Best wishes

Mouse

I don’t think that is correct Mouse1. It takes a while (a minute or so) but on my computer. Removing the files (moving them to blocked, trusted or deleting them) does update the number on the summary screen.

Have you guys just tried waiting a while and checking back later??

Cheers
Shaun

I noticed this bug over a week ago and it’s still here.

That’s not how it works Mouse. Whatever you end up doing with the files (purging, deleting, moving)… they are supposed to be cleared from that list and the count reset, for at that point the files are no longer “unrecognized”, you’ve made rules for them.

And Shaun, it’s been this way for days now. I’ve gotten a few more pending files since then and the count will then show 1 more than is actually in the box (i.e. 4 unrecognized files, when there are only really 3 in the box). Then when I remove those 3 the count goes to 1 again, though the box is then empty at that point.

I tried to close Comodo out quickly after removing those 3 things to see if they would then end up in limbo too… but the count updated “back to 1” immediately before I could… so I couldn’t test that theory about the changes not sticking if you close it out too fast. Sometimes the count updates immediately, but most of the time it takes a few seconds. Figures this time it would do it right away to foil my test. I encourage others to try this out though to see if that’s the problem. The last version updated the count immediately as soon as you cleared the box. However you got it to do that before… I’d stick with that. If it aint broke… don’t fix it.

Everything else about this new version, I love. It seems a bit lighter and I like the GUI better.

Fair enough you are correct! Forwarding to format verified.

Best wishes

Mouse

I have WinXP-SP3 + Comodo 5.0.162636.1135
And I have the same problem…
Is there any solution?

It says 1 Unrecognized file (for more than a month now) but nothing listed.

Windows 7 Ultimate x64 here and have the same issue, only in my case it’s 18 files instead of 1 ¬¬

All the new additions/purges stick and get deleted as expected, but these 18 ghost ones have survived cleaners, config. resets and windows restarts.

I just updated Comodo to 5.3
This 1 Unrecognized file is still there…

:frowning:

Update 5.3.176757.1236 Problem still exists… :frowning:

Is this maybe fixed in 5.4. Not experienced it yet, but only time will tell.

Mouse

Exactly the same issue as all the other reports, just with 3 files.
Here’s my post from the Defense+ help forum.

For the past 2 weeks in the Summery View window, Defense+ shows 3 unrecognized files.
When I open the unrecognized files window it is empty.
Even after Defense+ alerts for new unrecognized files in the summery, it will display these new files (today it showed a Secunia PSI dll) in the unrecognized files window and allow me to choose my actions like adding it to trusted files etc.
Then the Summery view will again show 3 unrecognized files while the folder is empty.
I don’t see any performance problems, all is running perfect, as it has for the past year.
Debug did not help, changing Firewall and Defense+ settings did not help. Defense+ and Firewall events windows did not indicate any unresolved issues.
My setup:
Comodo Firewall with Defense+, with Sandbox disabled. Version 5.4.
Microsoft Security Essentials.
Windows XP SP3 pro

I’d appreciate any help and suggestions.

Thank you,

Ta very much, already noted this and changed the fixed issues list.

Mouse

Bug still exists in version 5.5.
Do we have any news on that issue?

My number is up to 43 files now it…

I think I found a workaround!

I delete C:\Program Files\COMODO\COMODO Internet Security\database\pending.* files and the “ghost” unrecognized files disappeared.

The pending.* files created again after a new (real) unrecognized file appears!

If fixed by the workaround, does this now behave correctly in 5.8 going forwards?

Many thanks in anticipation

Mouse

Yes. Issue seems to have fixed in 5.8 (time will show)
Of course you have to delete the phantom files once and then everything seems OK.

Also I managed to reproduced the phantom files issue for those who have 5.5
Every time I m trying to apply Micro$oft patches to my WinXP machine those phantom files appeared!

I assume that M$ patches are creating temp files, recognized by Comodo,
but then the same patch file delete those temps leaving comodo with the phgantoms…

Thanks very much for the response

Mouse