Success Installing 64bit CAVL on 64bit LMDE 201403 Cinnamon

At Last! what can I say, this took me ages to sort out :o

so here’s my hopefully useful to others guide to getting 64bit CAVL 1.1.268025.1 installed on 64bit LMDE 201403 Cinnamon, Thank you all who have posted solutions that got me to this point, particularly Kinta Japan for the updated driver.tar and methods.

!) Firstly I needed to get these following files;

redir ( Install with Synaptic )
sqlite ( Install with Synaptic )
libssl0.9.8_0.9.8o-4squeeze14_amd64.deb ( From )
cav-linux_1.1.268025-1_amd64.deb ( From Comodo download page select Debian 64 bit (mint was tried first but this failed. My own errors)
drivers.tar patch ( From )

  1. Install redir & sqlite using Synaptic.

  2. Install libssl0.9.8_0.9.8o-4squeeze14_amd64.deb ( With Gdebi - just double click the .deb and it should do the rest, it sat next to version 1.0.0 without issue )

  3. Install cav-linux_1.1.268025-1_amd64.deb ( With Gdebi )

  4. Copy drivers.tar to /opt/COMODO ( Open Terminal, then type sudo cp /opt/COMODO )

  5. In the same Terminal, type/select sudo /opt/COMODO/ (use space bar to scroll down quickly through the license, then ‘Y’ , optional email,
    and language selection, then the patch will run.

  6. When this is done, in the same Terminal, type/select sudo /opt/COMODO/cmdagent then sudo /opt/COMODO/cmgdaemon

  7. You should now have a desktop icon, and menu items, if so launch Comodo from there.

  8. Open ‘Startup Applications’ , and create a startup launcher (if one hasn’t already been made for you).
    Type/Select /bin/sh /opt/COMODO/ login and past into ‘command’ box (create a title, and description if you want). Mine didn’t have it auto
    added, but yours might.

  9. VERY IMPORTANT using the now open CAV, update, but be sure to select the ‘never updated’ link on the RIGHT of the box, NOT the button on the left.

(This caused me several headaches as the updates just didn’t seem to work when I tried manually updating through terminal, or clicking the left Update
button) Clicking the Right-hand link immediately started a 200mb download with the words BASE_USER_UPDATE (don’t quote me on the actual wording,
I haven’t slept in over 24 hours, and can’t quite remember exactly what it was). This took a lot longer than the other update methods I tried before, and gave me the sense that at last I might have got it right).

  1. Log out, then back in to check if cav, cmdagent, & cmgdaemon are still running (I used System Monitor, even though CAV was in the taskbar, I wanted to check the 3 processes were working without disturbing CAV).

  2. if they are, then reboot…fingers crossed…and pray to Linus or whichever God/Hero/Demon has your back, it should restart and work, however, it
    has to be said, I did mine on a fresh install of LMDE 201403 (managed to completely bork my 32bit LM12 Cinnamon last Friday, and have had barely any sleep since).

Good luck, let me know if I’ve missed something, and if it has helped you.

Thanks again to everyone who has contributed your efforts/solutions, whilst all the other solutions I tried failed, I wouldn’t have had success today without
them, a bit learned from here and there.

The link for “drivers.tar patch” isn’t working.

Is this procedure valid for Mint 17?