Subscription alerts 'stored up' game mode & may cause memory leak [M249]

I had a nasty memory leak, and uninstalled cis in rage after it costumed nearly 10gb of ram, and bugged me with far to many renew subscription alerts. After I had calmed down I figured you might want to know as I had not seen the matter reported. Sadly I do not have all required data, but will do as best I can.

A. THE BUG/ISSUE (Varies from issue to issue)
[ol]- Summary - Give a clear summary in the topic title, NOT here.

  • Can U reproduce the problem & if so how reliably?:
    I could reproduce the leak whenever I entered game mode for a extended period of time (up to many hours).

  • If U can, exact steps to reproduce. If not, exactly what U did & what happened:
    Enter Game mode before the alert to renew pro subscription, eventually wait till one of the last days of the subscription period, when new alerts reappear rather often, and just enter game mode at any time. Wait a couple of hours. Now Comodo will have spawned hundreds of alerts with out displaying them and without closing the old one. Ram will run out.

  • If not obvious, what U expected to happen:
    I expected a single subscription alert once I left game mode, not hundred.

  • If a software compatibility problem have U tried the conflict FAQ?:
    I have tried 3 different games, all on steam.

  • Any software except CIS/OS involved? If so - name, & exact version:
    Sins of a solar empire rebellion - newest
    dungeon land - newest
    strike suit zero - yesterdays version, don’t know version number :frowning:

  • Any other information, eg your guess at the cause, how U tried to fix it etc:
    Already explained what I guess the cause is, fixed it by rage uninstalling comodo.

  • [b]Always attach - Diagnostics file, Watch Activity process list, (dump if freeze/crash).
    Sorry, forgot it.

B. YOUR SETUP (Likely the same for each issue, so you can copy forward)

[li]CIS version & configuration:
Latest (last update was installed yesterday). CIS 6.0 2708

  • Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV:
    Proactive defense, all modules enabled, and at default levels

  • Have U made any other changes to the default config? (egs here.):
    Only changed it to proactive defence

  • Have U updated (without uninstall) from a previous version of CIS:
    I installed V6 clean, later updates are from built in updater.

[list type=lower-alpha][li]if so, have U tried a a clean reinstall - if not please do?:
On it, but have decided not to renew my subscription, so can’t test.

[/li]- Have U imported a config from a previous version of CIS:
[li]if so, have U tried a standard config - if not please do:
[/li]- OS version, SP, 32/64 bit, UAC setting, account type, & VM used:
Windows 7 professional, 64-bit, UAC=default, No service pack, as my attempts thus far has failed.
It is running on a Norwegian language pack, No Virtual machine

  • Other security/sandbox software a) currently installed b) installed since OS:

UAC is on Standard.

I have attached a killswitch process list on mouse1 request, with the game I played the last time it happened running, but this is taken more then 24 hours after i uninstalled the pro version and installed the free version. The bug is not present here.

Edit: well, killswitch format was apparently not allowed for upload. Uploading in .xls instead, but have removed all the stuff that was not the process list. Tell me if you need them.

[attachment deleted by admin]

I’m sure if it’s a bug not your system Comodo will fix it. Having said that I see no point using “game mode” on or off it don’t make a big difference in the game really as I play Counter-Strike Online myself. As for the security “game mode” is not that safe so just don’t use it for now. That’s just a suggestion nothing else.

Sure, the main (usability) problem was that the renew subscription alert was coming up once every 2 min, as I only had hours left. This obviously made anything done in regular mode undoable. The main reason for reporting is was not that I was unable to work around it (uninstalling and reinstalling the free version worked fine), but it is a bug, and I figured comodo might like to know.

Edit: I apparently suck worse in spelling then I imagined.

Very sorry you have had this problem.

I realise under the circumstances you cannot add full information. If you can add the following information, I can forward:

  • OS version, SP, 32/64 bit, UAC setting, account type, & VM used[/b]:
  • Whether you have installed any non-Comodo security software since last OS install
  • Your process list may still be useful, but make claer that it was not taken at the point of the bug occurring

Here’s the standard request post which may help in other ways:

Thank you very much for your bug report in standard format. We very much appreciate the effort you have made to document this bug.

We are sorry to trouble you further but there are some items of information missing or unclear in your post:

See above

The reasons we need these items of information, though they may not seem directly relevant to the issue are explained here.

We would be very grateful if you would add these items of information so we can forward this post to the format verified board, where it is more likely to get fixed. You can find assistance using red links in the Format and here. If you need further help please ask a mod. If you do not add the information after a week we will forward this post to the non-format board. If this happens we will tell you how to rectify this if you wish to.

In the current process we will normally leave it up to you whether you want to make a report which includes all necessary information or not. We may remind you if we think a bug of particular importance.

Many thanks again


Oh just to note I have edited you post as I read it incorrectly to start with, and fear QA may do the same. I hope that is OK - please check to see whether I have correctly edited it.

Sure, I have no illusions of my English being perfect.

Will do. What do you mean by VM? As in virtual machine? Then I have used non on the current installation. Unless you count the cis stuff like the Kiosk, which I tried once.

Thanks very much, Yes VM is virtual machine. (Red links in format are to explanation) :slight_smile:

Just to check - have you installed any security software since last OS install? Your answer ‘no’ could apply to either a) or b) or both :slight_smile:

Thank you very much for your report in standard format, with all information supplied. The care you have taken is much appreciated by Comodo, and will increase the likelihood that this bug can be fixed.

Developers may or may or may not communicate with you in the forum or by PM/IM, depending on time availability and need. Because you have supplied complete information they may be able to replicate and fix the bug without doing so.

Many thanks again


Can you please check and see if this is fixed with the newest version? Please let us know whether it is fixed or you are still experiencing the problem.

Thank you.

PM sent.

I’d love to test, but my pro subscription has 274 days left, and I don’t expect to get the renew subscription alert anytime soon, and don’t now how to force it.

Thanks, Hmm not sure how myself. Sorry.

@QA Anyone from QA know?

Can you please check and see if this is fixed with the newest version (6.2.282872.2847)? Please let us know whether it is fixed or you are still experiencing the problem.

Thank you.

PM sent.

Can you please check and see if this is fixed with the newest version (6.3.294583.2937)? Please let us know whether it is fixed or you are still experiencing the problem.

Thank you.

PM sent.

Can you please check and see if this is fixed with the newest version (7.0.313494.4115)? Please respond to this topic letting us know whether it is fixed or if you are still experiencing the problem.

Thank you.

PM sent.

Sorry, the reason I never replied was I needed the subscription to run out again first, and as it still is some months away, it is somewhat hard to respond. I have not had any other similar issues since trough.

I understand. Let me know what you find once the subscription finally does run out.


I did not notice any repeat of the problem, seems to work now, thanks :smiley:

I’m very happy to hear that. I have now closed this issue in the tracker and will move this bug report to Resolved. If the issue returns please let me know and I can move this back to the main bug reporting board for processing.

Thank you.