"Submit files" bug (v3.0.013.268, x32)

I just installed Comodo (v3.0.013.268, x32) today, and keep getting errors while the firewall is learning about my system (HP pavilion mx70 desktop, WindowsXP-SP2, intalled Avast! v4.7 antivirus program). I have submitted several files via Comodo, but get the following error:
Network Error
Please check the network connection

This error happens with the following dialog window:
Submitting the file(s) for analysis…
Files are being submitted to COMODO. Please wait…

When I click on ‘Abort’ I get the “Stopping upload process. Please wait…” dialog with the progress indicators. Sometimes it takes several minutes to quit.

The following error message keeps coming up (seems to be linked to previous message):
Microsoft Visual C++ Runtime Library
Runtime Error!
Program C:\Program Files\COMODO\Firewall\cfpsbmit.exe

    This application has requested the Runtime to terminate it in an unusual way.
    Please contact the application's support team for more information

Other information:

I also installed “SafeEyes” from InternetSafety.com, a parental-control package. Also, some of the files I submitted to Comodo were HUGE (100+MB); don’t know if that was part of the problem. Each time after I pressed Abort (see above), after it finally aborted, Comodo would try again to submit the files and the error cycle above would repeat. I finally removed the files from the submit list and Comodo settled down.

Comodo seems like a great program, quite flexible. Hope this info is helpful.


I installed Cfp 3 upon its release and everything was working great. I had none of the reported bugs and was very pleased with the new version. That changed today. I tried to submit files to Comodo from my pending list and things went wrong. I have submitted files previously with no problems but today it caused my system to lock up and after waiting 20 minutes I had to do a hard shutdown. Upon reboot Cfp tried to resubmit the files and the same thing happened. I have now cleaned the files out of the submit folder and things are back to normal. The only knew software I have installed since CFP 3 is Open Office 2.3.
Next I clicked on Browse Support Forums under the Miscellaneous button and IE tried to launch. A D+ pop up appeared asking if I wanted to allow IE to access the internet and I clicked block and remember but IE launched anyway and brought up the forums. I use Firefox as my default browser and immediately shut down IE. My understanding was that if I clicked block the program should not have been allowed to access the internet.
I know these are not huge bugs in the grand scheme of things and they both can be worked around. They could just as easily have been mistakes on my part but any help is appreciated.

Vista Ultimate 32 bit
CFP D+ set to Clean PC Mode/ Firewall set to Custom Policy Mode
Avast 4.7 Home with all updates
BOClean with all updates
Spybot S&D 1.5.09