stuck in loop at updating data stage whilst trying to uninstall CTM from console

Hi I’m using Windows XP SP3 and have had CTM on my PC for a while now. I have CTM version 2.6138262.166 installed.

I started getting messages about delayed write failure popping up all the time saying there was insuffiicient space, but Windows shows I have plenty of disk space.

I deleted several snapshots, but I still kept getting the delayed write failure messages.

I decided to uninstall CTM by pressing the HOME key when I started my computer and restoring to the current version. The uninstall process has got to the ‘updating data’ stage, but it now seems to be stuck at 0% updating data.

There are 4 numbers at the top of the screen

00001111 00800003 00000000 75A00000

If I press the enter/return key I get a message dialog box saying

CopyUnits0: sector=FFFFFFFF src=FFFFFFFF

I then press enter/return and the same message dialog box appears with the same information.

What am I supposed to do now?

Any help would be very much appreciated

Hi… You shouldn’t abruptly uninstall CTM when you’re getting the " Write failure " message ! Instead you should have deleted even more snapshots and compacted the remaining ones till there’s no warning message before uninstallation ! ( Free space seen by Windows is exactly space used by CTM to store snapshots, so there is no sense to refer to Windows or other software when comes to determining free space left in CTM )

Since you’ve got this far, the Only thing left for you to do now is to uninstall CTM indirectly by rebuilding MBR with Windows Recovery Console etc ( which will disable CTM’s bootup console and let you log onto Windows ), then uninstall/clear CTM entirely in Windows console. You may then consider reinstalling CTM if you’d like ( recommend version 2.9beta ) !

p.s. you may provide more info. such us how big is your System partition and approximately how many snaps were kept when you uninstalled CTM, so others can help to determine what’s the likely cause of your foul-up.

Hi

Many thanks for your reply.

I deleted several snapshots, but that seemed to make no difference, which is why I decided just to uninstall the product. I also did compact the remaining snapshots each time, but if I remember correctly, the last time, it wouldn’t/couldn’t compact, but my memory may be faulty on that point.

I kept 3 snapshots if I remember correctly out of about 8 when the problem occurred. Obviously, I was unaware that I should not just uninstall CTM, if I was getting such messages.

Sorry, but when these unexpected things happen I tend to enter ‘panic mode’ and so do not keep precise notes of exactly what happened and what I do.

I guessed that Comodo was responsible for the delayed write failure messages and so I naively thought that by uninstalling the software, the messages would disappear. I did not think that the software would be unable to uninstall itself.

If I had just deleted all my snapshots, and not uninstalled CTM, would the delayed write failure messages have disappeared?

So, in summary I should just turn off my computer and try to rebuild my MBR as you suggest (I am not exactly sure how to do that, but I can try and find out).

However, how am I then supposed to uninstall/clear CTM in the Windows console as you suggest?

Do you mean using a DOS command prompt window that I should just go to the appropriate folder and delete all the files.( Are there any registry entries to be deleted?) or do you mean something else.

Apologies for my ignorance and thanks again for the reply.

Hi… The Second Topic from above has explained quite clearly how to rebuild MBR, you may also google up " rebuilding MBR " to enhance your understanding. It’s a relatively simple thing to do.

When you rebuild your MBR, CTM’s path on the Master Boot Record is wiped out and so is it’s bootup console. When you reboot your system, it will just boot right into Windows. And once you’re in Windows you just uninstall CTM as you would normally do with other software. ( No need to do the DOS command-line thing you’d mentioned )

As long as you have the system bootable and running make sure to Backup your data while you can…

Hi

Well I downloaded the minitool partition wizard home edition 5.2 iso and burned it to CD as you kindly suggested.

I then used the CD to correct the MBR, which the program claimed was done successfully.

i then tried to boot from the local disk to no avail - I tried using the last known good configuration and then various safe modes all without success.

A message on a blue screen does flash up when I try to boot but it goes so quickly I cannot read it and I do not know how to stop the screen so i can read it. I tried pressing the pause key but I seem to be too slow.

The partition wizard shows that my disk is there, but I do not seem to be able to boot up.

If you press F8 on boot you can select “turn of automatic reboot after bsod” that might help.

Many thanks for the tip. I can now read the bsod.

I am supposed to disable or uninstall any anti-virus, disk defragmentation or backup utilities and to run chkdsk /F. Quite how am I supposed to do any of that, given my current situation?
.

The STOP is 0x00000024 (0x00190203,0x8A89EF0,0xC0000102,0x00000000)

I tried again and got STOP is 0x00000024 (0x00190203,0x8A8BAB28,0xC0000102,0x00000000)
Unfortunately all this is getting too complicated for me.

I am going to have to stop for the day anyway as it is very late.

I’ll have to continue tomorrow.

Many thanks for all the suggestions.

doesn’t sound good to me, do you have a backup of your important data?

Thanks for your concern

No, I agree, it does not look good.

I am way out of my depth here really.

Comodo Time Machine is supposed to be my backup.

I think all my programs and data are there on my drive. Just Windows will not boot.

Use Windows Recovery Console on your Windows Installation Disc to see if your OS could be repaired or not ( if you still have the disc ), it’s obvious now that the OS has been messed up !

Ask a neighbor or friend to help if you could ! If it can’t be fixed you’ll just have to do a whole new installation of Windows. ( Before doing that take out your HDD and connect it to another bootable machine as a slave drive, copy your important files/data to other storage media )

Thanks

Unfortunately, I am having to reinstall from scratch, which is a real pain, as that also means loads and loads of programs to try to re-register/re-download and I also have to find appropriate user names and passwords and licence keys, plus program patches and updates etc etc.

Anyway thanks again

Hi, this is a bug caused by low space, CTM may fail to uninstall if there is not enough space on your disk. Now, you can try to uninstall CTM by rebuilding MBR with third part disk tools. If your system cannot start after rebuilding MBR, you will have to hook your disk to other system to get data back and then reinstall your system.
This bug has been fixed in build 2.9 BETA.

Hi

Many thanks for the information.

I was afraid that was the problem right from the start.

Perhaps CTM, in future could a) tell the user that they need to remove ALL snapshots before uninstalling
and b) perhaps CTM should check that there is sufficient space to uninstall itself and when it is getting near that limit tell the user and not take any further action until there is sufficient safety margin.

It has taken me 3 days to get back to having a working system and unfortunately I no longer trust CTM. It caused the exact problem it was supposed to prevent.

Thanks anyway