StripMyRights, CIS and Internet Explorer


There is a problem between CIS 4.1.150349.920 and StripMyRights utility that can be found here:

StripMyRights by setting the registry for Internet Explorer (IE) can strip down access rights for IE limiting the risk of surfing the Net with administrator rights.

The registry setting for IE is:

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Image File Execution Options\iexplore.exe]
"Debugger"="StripMyRights.exe /D /L N"

Similar registry settings work well for other applications like Firefox, Outlook Express
but not for IE! StripMyRights.exe is well in safe applications list, and theres is anomaly in alert chronology by CIS:
1- allow StripMyRights.exe running
2- allow StripMyRights.exe runing iexplore.exe
3- allow iexplore.exe running StripMyRights.exe (<= anomaly here: recursivity?).

The result is that double click on IE does not show anything.
Im am running XP SP3.

Thank you.

You should have mentioned, that we’re talking about IE8.
If you use a tool like Process Explorer, you’ll see, that at startup, iexplore.exe launches itself and creates an iexplore.exe child process. Therefore also StripMyRights will be launched again in the above scenario.

Did the “registry method” work for you before with IE8?

It’s a problem with the process architecture of IE8 and using StripMyRights as debugger. As I remember, it worked well this way with IE7. With IE8, I’m using the “command line method” and launch my IE with StripMyRights.exe “%ProgramFiles%\Internet Explorer\iexplore.exe”.

But I never tried if it would work without CIS.


You should have mentioned, that we’re talking about IE8.
You are right, it is about IE8.

Did the “registry method” work for you before with IE8?
No, this never worked for me, and now I have the answer from your explanations
of internal working of IE8.

For your information, the command line method:
%SystemRoot%\system32\StripMyRights.exe /L N “%ProgramFiles%\Internet Explorer\iexplore.exe”
works well, no problem so far with CIS.

Thank you again, and since this is not a CIS bug, please close or move this topic.

Thread has been locked as per OP’s request.
If you require it re opened, please PM any Mod or Admin.