Strange Update Glitch

Hi all,
Long time lurker, just never got round to registering.

Around ten minutes ago i did a manual update of BoClean (said no updates)

A few minutes later the auto updater kicked in and gave a warning that it couldnt connect. Said either FW blocking, which it is isnt, (especially as I casn manually update) or server down

Using Comodo FW by the way

Thanks in advance


It will check for update automatically every time at startup according to the configuration and so it may automatically checked for update. There may be no update so it may displayed that message. :■■■■

thanks (:WAV)

You misunderstand. i have changed the config to suit myself.

The problem was the auto update told me it couldnt connect or server was down minutes after I had done a manual update

Hi Huwge and to virus as well. (:WAV)

I’m guessing. Perhaps the auto-update failed because you were running the manual update (port, files, etc… locked) at the same time & it then waited on a timeout. Try to replicate the conditions… if you’re happy to look for trouble of course. ;D

We’ve seen a few problems now with folks unable to get the updater working properly and I think I might know where the problem might be hopefully. BOClean does a “PASV” (passive) FTP download of the update as a result of firewall behaviors by ZoneAlarm and several others and PASV was what solved many of these issues over BOClean’s existence. We’ve tried redesigning for HTTP downloads but unfortunately HTTP isn’t always reliable and often results in corrupted downloads. Doing the updates via FTP is how we ensure that the download precisely matches what’s on our server.

According to Microsoft, those trying to go through a proxy or with some firewalls might not be able to successfully download owing to a default setting in Internet Explorer which is picked up by the BOClean updater. Therefore, I’m curious as to whether or not this does it for those who have been having problems. Give it a try and let me know - if this takes care of it, then 4.24 might be able to be released next week with all “todo’s” resolved … according to Microsoft:

To resolve this issue, turn off folder view for FTP sites in Internet Explorer:

  1. Start Internet Explorer.
  2. On the Tools menu, click Internet Options.
  3. Click the Advanced tab, click to clear the Enable folder view for FTP sites check box, click Apply, and then click OK.

Will be back tonight to see if this solves it after I get some sleep. :slight_smile:

Thanks for the reply Kevin.

When I booted up today BOC updated properly…only thing I notice is that I dont have a tick in the to disable the auto update box but I dont see it.

I havent changed anything since yesterdays glitch…so hopefully it was a one off :stuck_out_tongue:

you could also try adjusting the setting in IE/tools/options/advanced for “allow passive FTP”…

I dont use IE :stuck_out_tongue:

Ah… but Internet Options that is in MSIE is also in your Control Panel. And as such, other applications use Internet Options for connection method/type, etc. Bottom line, you don’t use IE sure, but other applications use IE on your behalf. ;D

The fix seems to have worked for me. No problems. (:CLP) Well at least it is ok on one of my computers. The older one still isn’t working. (:SAD)

This problem just started today. Changing the options in IE did not help. I did find that it might be a conflict with kaspersky. Turning off the firewall and pdm does nothing, you have to shut down kaspersky to get the updates to work. (applys to kis 6 +7)

Hi Jealous-Dog, welcome to the forums.

Whilst there has been no official word from either Comodo or Kaspersky, we have learned through the forums that there have been instances where CFP and specifically KIS, because of its firewall component, seem to conflict. We also learned recently that KAVs refuses to installed when CFP is present due to “conflicts”. So, Kaspersky are obviously aware of “something”. I can only recommend that you go to Comodo Support, register on their system & raise a ticket on this issue. And to perform the same action with Kaspersky. We’d appreciate it if you posted back any feedback you get from either party, if you do this. Thanks.

Well I discovered that somehow my system date was put back by 1 day.(malware maybe) This was the cause of the problem for me. Comodo support did get back to me and said it was the mini-filter and linked me to a thread in the KAV forum. Kav support told me I was not entitled to tech support because I got my key from systweak (legal key still good), and to contact there support. I did send them the info but they have not gotten back to me. I dont expect much help from them as they are a reseller from what I know.

Thanks for the feedback Jealous-Dog2. :slight_smile:

No support because you purchased your version from a reseller?!? That doesn’t sound very fair to me.