Strange Situation, Just wanted to share with you

One month back I installed CIS 6 on my friend’s system, I do not remember the version number (must be the one with no TVL).

Today, as he was constantly complaining about strange system behaviour, I visited his place and was surprised to see the situation.

When I installed CIS, I have put BB to “Fully Virtualized”. I do not know what actually happened and how it happened, but here is what I saw.

[i]Everything, including CIS executables were sandboxed. What ever was running there was running with a “Green Border”. The explorer, Command Prompt, Add/Remove Programs (even when invoked from appwiz.cpl command, Comodo Uninstaller (msiexec itself I suppose) were running with “Green Border” i.e., “fully virtualized”. :o :o :o

Any tool I try to use is running “fully virtualized”.

I tried hard but could not get CIS main screen or tray icon. The widget too was missing. ???[/i]

I wished to have a ghost image of the system, but my friend would not let me spend more and more time with experimentation.

I had to format C drive and reinstall Windows.

Just wanted to share this funny surprising experience with you. ;D ;D ;D

To me that sounds like perhaps the TVL and TFL were both corrupted. Did you try running the diagnostics?

As I mentioned earlier, I could not get CIS main screen or widget or tray icon…

Sorry, I missed that.

Did you try restarting the computer in Safe Mode?

Yes, It was running in Safe Mode. But there was not muchI could do in Safe Mode either. When I try to uninstall CIS, it wont. That is why I decided to completely reinstall Windows.

The CIS window did not open in Safe Mode too…

Did you try running this uninstall tool from SafeMode?

Also, exactly what happened when you tried to uninstall CIS from Add/Remove when the computer was running in Safe Mode? What do you mean when you say it just wouldn’t uninstall? What did happen?

By the way, I’m asking all of these questions because I want to figure out the best approach to take if this happens to anyone else’s computer.

No, I did not. Since, I had to download it from net and it was not present with me readily. Besides, What ever I was downloading from net, were being put in Virtual Space since Both IE and Firefox were running Virtualized.
I also heard that the tool was to be used after standard uninstall. So, I did not try ■■■■■■■ that.

In Safe Mode “Windows Installer Service” does not run. Therefore, CIS uninstall does not continue.

Do you mean that even in Safe Mode applications were being run as FV? If so that’s very strange. Hopefully someone can explain how that is happening.

For future reference it can also be run in situations like this, where it’s not possible to uninstall CIS normally.


No. Unless we enter Safe Mode with Networking, we do not get internet. In normal Safe Mode, there is no way to connect to internet and download.

I was referring to “normal boot” for downloading.