Strange Problem I am having connected to the Virtual Kiosk I believe?.

Since last Friday I have experienced the following problem. My default browser is Ice Dragon, I also have IE10, Firefox and Dragon installed as well all kept up to date and used now and again just to keep my add-ons etc up to date. My OS is Windows 7 and I made a clean install of Comodo v6 from v5.12 about a month ago. Last Friday using Ice Dragon I attempted to log in to my online banking account at the NatWest site here in the UK. I have done this about once weekly for a long time with Ice Dragon now but previously also with Dragon and Firefox without any problems. My usual bookmark opened up on the NatWest opening screen but when I clicked on the Log In button in the purple box top right on that page it timed out and I got the normal time out message for this occurrence. After getting the same result several times in succession and still unable to sign into my bank account I tried with each of my other installed browsers getting the same results with them as well. All my other bookmarks are working the only problem is with the NatWest log in option.

I thought at first that it must be a security issue and so I checked out my NoScript, Ghostery, Peer Block programs etc, etc but found nothing untoward in any of them and as I say all other internet traffic is working fine. I went to the NatWest online help and found no solution there either I phoned them and the chap I talked to couldn’t figure it out either but assured me that there wasn’t a problem with their site. I then tried using the links to the sandboxed browser links from the widget but still couldn’t log in. I next tried the Virtual Kiosk feature imported shortcuts to IE10, Firefox and Ice Dragon and started with the default Dragon browser but still couldn’t log in to my account from the NatWest screen.

I closed the Virtual Kiosk and as a last attempt tried Firefox and hey presto I got logged in. I checked my account and then exited. I then found that I could log in to my NatWest account via Dragon and IE10 as well but not with Ice Dragon. I then went on Google and tried with no luck to find a reason for the problem I was having. This morning I had to reboot my PC as part of a Video card update and later I went to sign in to my bank account only to find that I had the same problem again. I went through the whole rigamarole again and still coudn’t get logged in. I thought on what I had done yesterday prior to getting access then and remembered that I had come from the Virtual Kiosk before opening the normal version of Firefox. I did this again with no luck the first time but then attempted something which turned out to be a solution for me.

If I open the Virtual Kiosk and then leave it by using the return to Windows option offered I can then use the normal desktop shortcuts to Firefox, Dragon and IE10 (Ice Dragon does not work for some reason) to go to the NatWest site and log in to my account as I normally do. If however I leave the Virtual Kiosk by the Exit option I cannot connect to the sign in screen at NatWest and cannot access my account. I have absolutely no idea why my browsers are behaving in this manner but have tested it a few times now and crazy as it sounds that is what is happening. Has anyone else experienced any similar problems with the Virtual kiosk?.

Today my daughter left me her Windows 8 OS 64bit laptop to update it from CIS v5.12 to CIS 6.0 and before I uninstalled CIS v5.12 I was able to access my bank account from both her browsers IE10 and Comodo Dragon. After I installed CIS v6.0 and set it all up using Chirons guide at Gizmo’s site I tried again to access my online bank account and found that I could using IE10 but not using Dragon. I find this extremely odd that all the other internet sites we try work ok except for this one site and like I say we can access the NatWest website ok we just cannot access the log in page. Below I have left a shortcut to the NatWest site. Could any one of you attempt to do what I have tried to explain and see if the same happens for you. You do not need an account there to log in, just use the link below and click on the Log In button top right and let me know if it is working for you and which browser you are using. Thanks a lot if you got this far.