Strange firewall messages

I have been using your excellent firewall for a dew weeks now, generally with no problems whatsoever (L). Within the last week or so I have been getting a number of warning messages, usually when I am trying to connect to the internet. I get the options to ‘Allow’ or ‘Deny’, but never to remember my decisions. Here is one such message:

The parent application [System Process] refuses communication with COMODO Firewall pro. This may happen because [System Process] has crashed and needs to be restarted, or it has installed potentially dangerous kernel level hooks to reveal its activities.

There is some more dialogue stating that such activity can sometimes be caused by anti-spyware or anti-virus software, so for your info I have installed the following:

Avira Antivir Personal Edition Classic
Spyware Terminator (realtime protection and HIPS enabled)
AVG Anti-Spyware free edition
AVG anti-rootkit
F-Secure Blacklight
Panda Anti-Rootkit

I scan regularly with the above and to my knowledge have no infections. Any advice as to how to resolve this issue would be greatly appreciated, as this is driving me nuts. I tried reinstalling COMODO Firewall Pro a day or two ago - all seemed well to begin with, but then the same problem re-emerged. :stuck_out_tongue:

It looks like possibly one of your other security apps can’t communicate with the firewall. I know there have been several discussions on KAV here that give the same error message as you are getting.

Could be a recent update to one of your programs might have changed something in the way that program sees the firewall now.


Hi Jasper,

Thanks for the suggestion - how might I fing out if indeed this is the problem, and what could I try to fix it?


Some things to try:

  1. Check the Application Monitor section of the firewall to see if possibly something is being blocked there.

  2. Disable the antivus or maybe the on access scanner part to see if that changes anything. Do the same with all of the real-time security programs only disabling one thing at a time so you will know where the problem lies if it gets fixed. You want to be careful here as you would then not have any antivirus protection if you do this while connected to the internet.



Nothing in the Application Monitor or System Monitor is blocked. I have tried disabling Spyware Terminator’s real time Protection, ST HIPS, Antivir and BOClean one at a time; I keep getting these messages whatever I do. ??? Any suggestion?


Did you install any of the other security apps just recently?

Did you go into Task Manager and kill any running processes from there also for each app after shutting them down?

Every time that I have seen a thread with that log entry it seems to always be the antivirus having problems with the firewall. Have you looked in the AntiVir forum to see if anyone else is getting those errors?

I’m not sure that reinstalling the firewall would fix it but you could try and reinstall the firewall in Safe Mode or uninstall the firewall and reboot then disable all real-time security apps and then reinstall the firewall.


Will give all that a try. Having glanced at other threads, am I right in thinking that many people have been getting random messages since the most recent Windows Updates? Some of the messages involve processes like svchost.exe, which is mentioned in several of the other messages I’ve been getting. Could this be the issue? I’ll be away from my computer for the weekend, but will try the avenues you suggest early next week and get back to you if I’m still having any difficulties.

Thanks again for the advice,


That is a possibility. I don’t want to rule anything out. Let us know what happens.



Just to let you know, I managed to solve this issue by following dogstar’s advice in this thread:

I applied this fix two days ago and have seen no re-occurrence of the odd pop-ups.

Thanks again for your time,