Strange events

Dear developers and users,

today I’ve experienced some strange events with Comodo firewall.

First, a message appeared telling something similar to “Network Monitor is down. Reinstalling the application may solve the problem.”
I restarted my PC and all seemed to be ok.

Next, another message appeared telling me that “Security level was changed to ‘Allow all’”. But I didn’t change it!

What’s happening? Is someone trying to attack my system? I’ve got ony one open port, the one for eMule…

This has happened to me before, but very rarely. I also would like to know the answer. An attack is one possibility, but this happened after I updated a Windows patch and rebooted.

Do you recall what last occurred before the strange events?

I don’t mean to scare anybody, but does it have anything to do with Matousec’s latest advisory? There’s no malware on my pc.

You cannot scare me anymore, I’m already scared enough ;D

However, those strange events all happened after switching user with the ‘Fast User Switch’ method. Futhermore, eMule MorphXT 9.5 was running.

I know ‘Fast User Switch’ can cause problems to some applications, but this does not reassure me at all. :’(
I used ‘Fast User Switch’ with Comodo without any problems until now…

Check out this thread about faster user switching:,6441.0.html

It isn’t the same thing. They’re thinking about the Security Center balloon appearing sometimes when fast user switching, and I’m definitely not talking about it. This is something really more severe: CPF has been actually disabled, its policy being changed to ‘Allow all’.

One possibility regarding the switch to Allow All…

I came across that a few times in the past, and apparently the control is very sensitive (or rather, interfacing with it). Thus, if a user clicks quickly in the systray area and/or rolls the mouse scrollwheel, it is apparently possible to inadvertently cause it to change.

I was a bit of a “super-clicker” prior to that; realizing what was going on cured me of that habit.

I cannot say that is what happened with your case, but it’s the only thing I have personal experience with. If you monitor the situation, and do the user-switching some more, try to see if it reoccurs when you know you’re not clicking in the systray area. If it no longer happens, perhaps that was the problem. If it does happen, and you can quantify that clicking is not the cause, I would file a ticket with support post-haste.


Maybe someone should’ve implemented hotkeys then…

I only use keyboard shortcuts within applications; and I use those a ton… Mouse is too slow… It’s an old habit from the pre-Win days, where if you wanted to do something in WordStar, ProfessionalWrite or SuperCalc (4 or 5) quickly, you had to know the shortcuts

So now I just learn what each app’s shortcuts are, and use 'em… But the desktop is a different matter, and if you move the mouse quickly, click fast, you may end up grabbing stuff ever-so-slightly, which is what I think happens with the security setting.


Hello, everyone. My firewall is totally disabled after I run a Spysweeper sweep. It also happens when I run a NOD32 sweep. Always cured with restart though. It’s not a problem as I’m not on the internet when I scan.


What version do you have, of each application in question?

Can you explain more what you mean when you say the FW is “totally disabled”?