Strange DNS problem?. (Help Needed)

On trying to open my bookmarked link to the Ebuyer site I cannot get access although all my other bookmarks are working fine. I tried using Firefox, IE9 and Google Chrome but get the same result each time. I posted the problem on another site and was advised that it could be a DNS problem and tried the two options offered there. One was to try a traceroute, the result of which was “request timed out” and the other was to ipconfig /flushdns which I did and was told it was successfully done but I still cannot access the Ebuyer site which the people on the other forum told me was working fine for them so it isn’t a problem with the site in question.

As I use the Comodo DNS service with the latest version of CIS could the problem somehow be with Comodo?.

Any advice offered is much appreciated.

Try changing to other DNS servers. Then flush you dns cache again and see if you can reach the site. If you can reach the site Secure DNS is blocking. Then please consider reporting the site in Report Blocked Sites You Believe Are Safe Here.

Thanks again for the reply EricJH, I changed to Open DNS servers but still couldn’t connect so I flushed again and reinstalled the Comodo servers to no avail. It is very strange as it is the only site affected in this way. As I bought an external hard drive there recently I checked my Paypal account for the time and date thinking that I may inadvertently have blocked it via a Comodo pop up at the time but there are no corresponding events in either the Firewall or Defence Plus. I will take your advice and reportthe site to the link provided.