Stopping WMP 'phoning home

Just built a PC for a friend and will install CIS on it (but use only F/W and D+).

The OS is XP Pro SP£ (nLited of course) but I’ll leave Windows Media Player (spit) for him.
WMP has options for looking for updates at various intervals but no option for ‘Never’, so I would like to block it from getting out but still allow it to play videos on sites that need WMP (spit).

Is there a way of doing this in the firewall?

I always block it using the predefined Blocked Applications rule, but technically I don’t think it’s really necessary since after you disable all internet related options in WMP, the only thing left it does is open a UDP connection for DNS lookup.

yebbut, the update isn’t disableable(?).

Yes it is. In addition to disabling all available options in WMP, I Enabled these in Group Policy Editor (start > run > gpedit.msc):

Computer Configuration > Administrative Templates > Windows Components > Windows Media Digital Rights Management:
Prevent Windows Media DRM Internet Access

Computer Configuration > Administrative Templates > Windows Components > Windows Media Player:
Prevent Automatic Updates

User Configuration > Administrative Templates > Windows Components > Windows Media Player:
Prevent CD and DVD Media Information Retrieval
Prevent Music File Media Information Retrieval
Prevent Radio Station Preset Retrieval

User Configuration > Administrative Templates > Windows Components > Windows Media Player > Playback:
Prevent Codec Download

Do note that XP Home doesn’t have Group Policy Editor (although there are equivalent registry tweaks).

OK, thanks for that - I’d never have found it.

Now I know why I don’t have the junk - trouble is, there are a couple of sites where I could do with it for videos. Haven’t found a way of making Opera play them - the sites just invite me to d/l WMP :’(

Nice info errrr, whateveryournameis :wink:

Thanks :-TU

Get the this useful installer for the Firefox plugin:|_Plugin.exe . It will look up installation(s) of Opera and will suggest a plugin folder to unpack the npmswmo.dll to. When done restart Opera to test the plugin: .

While editing and previewing I see the url for the plugin is not picked up properly. Please copy/paste it to the address bar of your browser.

Yes, that’s what I want to do. On my PC I don’t have WMP at all, only codecs from WMLite. On the new PC it’s the one with XP Pro SP3.

Thank you Eric, I’ll try it. Ah, the download button is dead, don’t know why ???

Sorry bit late I know but if you make this a blocked app it stops it setup_wm
I do not have this problem now since I run it sandbox it does not try.

Finally got it but I appear to have gad it anyway. npmswmo.dll is actually npmswmp.dll, as I found out by extracting the download to its own folder to see what was inside.
Both test sites will play the video but the one site so far that I’d like to see won’t

OK, tried this and getting a bit more result: ‘Connecting to media…’ ‘Ready’ but no more. Just checked the settings as per your pic, thank you for that, and mine are the same :frowning:

!ot! Yep, we are in the same boat regarding WM in Opera. However, I’m currently only vaguely interested in resolving the problem. If a topic is started I may possibly join though.


@Giraffe PC. That page plays here in Opera 9.62 and 10 alpha (it doesn’t show the controls witn 10a; I will report that at the Opera forums).

Please try the following basics:
Clean cache and cookies and restart Opera
Disable content blocker for that page as well as external ad block/proxy programs.
Disable userjs scripts when using them.
Does that help?

OK Eric, had a go at that and still won’t play.

I will not install WMP!

Excuse me butting in but could somebody please tell me how “Phoning Home” effects a computer.
For the last two months my no 2 computer has some very peculiar effects and i am wondering if it is caused by phoning home.
About every 3-4 days it deceides to go slow that is in trying to open a program takes about 1 minute instead of a fraction of a second.This will go on until i reboot and even this takes 3 times longer than normal.
I have tried everying i can think of and then i saw the post about “Phoning Home” which made me wonder if that is my problem.
Help would be very much appreciated.