stopped creating rules for safe apps

Yesterday a friend, also a CIS user, came to me to ask why he doesn’t get no more popup windows from firewall so I tried to test it:

  • Safe Mode set
  • create rules for safe applications - disabled
  • rule ANY ANY ANY for Opera removed
  • rule ANY ANY ANY for Total Commander removed
  • settings confirmed
  • Opera and Total Commander started and connected to the Internet without neither popup window nor any rule re-creation


  • the mentioned rules for O and TC are re-created
  • uTorrent started and connected (up and download) without neither popup window nor any rule re-creation

This worked perfectly a while ago. Now it doesn’t neither for me nor for my friend.

The latest v of CIS 4
Windows 7 x64 (mine)
Windows 7 ??? (friend’s)

First start with enabling “create rules for safe applications”. Then you will get rules created.

What configuration is your friend’s computer using? The default Internet Security or Proactive Security?

It’s weird that I got those rules created before without that option enabled. My friend uses Firewall Security configuration for some reason…

I’ve just got a rule created without doing anything:

  • had uTorrent as blocked and Custom Policy mode
  • uT started and then closed
  • uT block rule removed and firewall switched to Safe Mode
  • uT started, connected
  • uT rule created automatically (still with “Create rules for safe apps” disabled)

Same for Opera.

i.e. everything’s fine again (?)