stop parent alerts

Is it somehow possible to set CPF not to alert me about parent changes if i grant internet access to an application.
Even if i set “skip parent” it asks again and again. I just want one entry in the application list with the meaning of … “yes, this application has full access to the internet no matter by which parent it has been started, please don’t ask me anymore until the application changes”.
This is because i want to run CPF on a server and i cannot deal with all those alerts the whole day long. So i need to disable these.
Again, if i add an application to the application list and i allow internet access for it, i don’t want to be asked about any parents in future.

Sorry, i searched the forums for 60 minutes and found nothing.
Please help me.

Welcome to the forum.
First, have you scanned for known apps?
Then, when you add an app, go to security/tasks and “define a new trusted application”
Then you can go to security/advanced/Application Behavior Analysis, and uncheck “monitor parent application leaks”. There might be something else there you want to uncheck.
Then you should go to security/advanced/misc, and put the alert level slider to the bottom. Also check if “do not show alerts for …” is checked.
I hope this helps.

Remember to restart the firewall, or maybe reboot the PC.