Still Trying to Update


Let me define my problem and what i do in every step;

  • First of all update notification appeared to update latest comodo vers.
  • I tried to update via Automatic Updater but it didnt worked and it continued to display “update available” message,
  • I tried to run updater file via “run as administrator” but by using this automatic updater cant find an any update,
  • Then i decided to uninstall and install new release,
  • But it still displays update available messages …

How to solve this issue ?


Did you install the LATEST version?


Goto miscellaneous/settings/update,uncheck box marked automatically check for the program updates.
If you do this it would be a good idea to check here or Comodo site often to make sure your up to date.


yes i have latest version … clean install …

Same issue here. Tried suggestion given. Still no change. (sorry for butting into thread)

Add me to the list of people who have had no problems with automatic comodo updates and find them to be unmitigated blessing.

But clearly we have at least two people who are not experiencing the blessing so we should all wonder why.

To take a little wild stab in the dark, as someone who almost always uses firefox, I sometimes find the internet explorer web browser has been closed in the off position. And its my understanding that comodo along with some other update type programs do their updates through internet explorer. And I have experienced failures of these updates when internet explorer is closed in the off line position.

Sure not saying that has to be the case here, but its one possible troubleshooting step to try.

(Thread hijacker here)
Tried suggestion above (also a Firefox user) but no luck. Even when I try to manually update Comodo it states that the updates were installed successfully but when checking for updates immediately afterwards it states that an update is available as if I never installed the original update.

To bgfunk76,

Question, do you get updated to the new version or not? Quite a few people were having the same problem a number of versions back, but another update down the line it went away, it least in my case.

Same as the OP. I have the latest version.

Some people do have problems auto updating, Including my self in the past, so am I apart off your “unmitigated blessing” ?

Pls take this into consideration.


I tried updating when IE is active but no luck …
It asks for update, tries to update, complete the action and repeat the same scenario everytime i open the computer or so …

I have the same issues.
I’ve updated, and still shows the notification of updates availables

When i do the “run as administrator” trick, it doesn’t show any update available, but as a normal user it does

O.S.:Vista 32

Trying to update CFP as I write this. Neither auto or manual-u functions properly. Cant get past 8%. CFP Diagnostic tool showed no problems.

Update was no issue last time (last week or so) and I have this problem on desktop with XP Pro SP2 and on laptop with Vista pre and post SP1.


BUMP still no success

Hi guys,

Please do a complete uninstall off CFP 3, Then Download & Install latest.


Ive tried that before posting this thread …
I completely uninstalled cfp and reinstalled it, but it is still asking for update … The funny thing is that i already installed the latest version …

This has happened to me in the past…

Have you tried using the Reg+File Remover that Ragwing posted here?:


No, i uninstalled via Uninstall tool of comodo firewall …

I may try that …

Let me know your results.

Use the Reg/File Cleaner AFTER uninstalling CFP 3 and rebooting.