Still having problems related to COMODO CIS!

I made quite a few posts last year after I had major issues uninstalling Comodo 5.5 FW. So any party that is wi lling or able to help could you take the trouble to read those posts which can be found searching my user name. Theirs a fair bit but all under one topic relating to major uninstall issues.

Well since September 2011 I been running relative problem free untill quite recently. Have been suffering hangs/freezing of IE8 and my laptop seemingly running a little hotter than usual. Finally a few days ago my laptop just suddenly shutdown for no apparent reason. Tried various things to get it restarted and eventually got into Safe Mode Ok. Tried to restart normally but it failed to boot up again. Then tried restarting again without the battery insitu and running on ac power only and managed to get Vista back in normal mode. Re-inserted the battery and it’s been running since, and rebooting each time since.
My impression is that it may have been a thermal shutdown but can’t find any evidence of such.

So I’ve been intouch with the folk over on the Bleeping Computers Forums re the EI8 issues and the sudden shut down. They have had me run a M iniToolBox and have quite rightly indentified I have CIS shown installed

Sorry had to split my post …yet again here… as the text box was acting up.
Fporgot to say that after the shutdown issue I took a look at the Event Viewer which shows that since 21/6/12 I have been getting lots of warnings and errors reported of various types. I personally can’t relate these to Comodo or Avast.
As I was saying Bleeping Computers identified I CIS shown as installed and suggested that this could be causing issues with AVAST AV (which I have been using for several years now) and suggested I uninstall Comodo and this may solve the errors and warns in Event Viewer.
I’ve tried a few of their other suggestions 1st including running chkdsk /r without any success and finally took the plunge and tried uninstalling comodo yet again!
1st of all to stop any issues from AVAST I completely uninstalled this. Then tried to uninstall Comodo from Program and Features (I’m running Vista Home) and low and behold I get the same old error message that I couldn’t resolve last year! The message is as follows:-
A network error occurred while attemptiong to read from the file “C:\Windows\Installer\CFP_Setup msi.”
At a total loss as to what I can do here and I don’t want to completely re-install Vista for the want of a very badly built uninstaller from Comodo.
Does anyone here have anything to offer to help me out at all to get rid of Comodo finally off my system. I’ve lived with it for the last 14 months without any real issues until recently it seems.

Try following this guide to completely remove CIS and reinstall

Hi wasgij,

Well finally got rid of Comodo following the guide, although had gone through most of this before. Only things I can think of which were different are using Revo Pro this time round and if the Comodo uninstaller has been tweaked some since I last tried. Also uninstalled Avast before trying all this and ran their uninstaller tool in safe mode.
So a big thanks for your advise.
Oh and I shan’t be installing Comodo again in a hurry! I still have to try and get ot off my wifes laptop as I wouldn’t risk having hers crash on me, she’d have to lots to say!!