Still Getting Alerts When Ruleset/Custom Rules Apply

I am limiting the accepted addresses able to connect to an application. I first did so using “application rules”, but I was still prompted each time a connection attempt was blocked by these rules. I next defined a “ruleset” and applied that to the application but I continued to get alerts when the ruleset properly handled the connection request.

The ONLY options available to me on the alert are options that essentially override and destroy the carefully crafted rules I have created for the application.

I don’t want to turn off all alerts.

I simply want to avoid receiving alerts for this given application, or more generally when predefined application rules or rulesets effectively handle the event.

As is I am constantly having to ignore popup spam from this firewall eventhough everything is working properly.

Any simple misclick (easy to do given the frequency and size of these alerts) overrides my rules. Quite annoying.

I am not sure, but would it help you to create one (bottom) rule for such an application rule set:
Block all any any?
All rules above it are handled. Everything else gets blocked unasked.

Also use the port wizard to block ingoing unasked. Stealth port wizard in comodo.

The ruleset does have a bottom catch-all rule to block all traffic. Unfortunately this doesn’t stop the alerts.

I just disabled all alerts to fix the problem. It’s a poor solution, but I don’t see another option.

Can you give a randomized example of such an alert? (Together with the headline)
And a randomized example of the related ruleset?

As I was typing out the Ruleset I noticed that my catch-all block was only set for incoming traffic. After fixing that I haven’t seen another alert.

Thanks for making me recheck my work.