steam DOD:S

When I start DOD:S it completely locks the PC as soon as I try to find servers. Deactivating Comodo allows me to play normally. I tried adding hl.exe to the application monitor, but that does not help. How to configure to allow playing DOD:S with Comodo active?

your PC may not actually be locked, it may be waiting for you to reply to the CPF security popup that you cannot see.

One way to know if you are “locked” would be to check if NumLock still cycles… if the light goes on/off/on/off without issues, your PC is not locked.

I don’t have DOD:S, but do have CS:S… in order to get CS:S to connect and behave properly, 2 things needed to occur:

  • Add a tcp/udp in/out rule for c:\games\steam\steamapps[i]useraccount[/i]\counter-strike\hl2.exe… I execute CS:S through the steam client, so I set C:\Games\Steam\steam.exe as the parent and Allow invisible connection attempts.
  • hl2.exe will also call for interaction with dinput.dll (part of DirectX). So you may want to check the Component Monitor to see if dinput.dll is in the list, if not you might want to try adding it manually… it is located at c:\windows\system32\dinput.dll

With these set, I was able to launch CS:S from Steam, browse for servers, check the server properties, see people logged in, get a ping count, connect to the server, and pick a team to start playing.

I however was able to force access to my CPF popups, and answer the rules, then tweak the app rule after (as I had many hl2 rules that I consolidated into the one rule listed). I’m not sure if manually adding dinput.dll has the same result as answering the popup… so hopefully doing these things manually works for you…

That is most likely the case but since alt-tab or ctrl-alt-del doesn’t get me back to the desktop so I can answer the popup, this is as locked as a computer can be. :slight_smile: I’ll try your settings.

You said something about force accepting popups… How do you specify that.

This worked, thanks! (I set the parent to “learn”)

That’s great! ;D

FYI… another key sequence to try break a full screen app is Ctrl-Esc (keyboard shortcut to launch the Start Menu)

The answer provided to this problem probably works for the “ordinary” steam users. I have cybercafe steam licence, steam for cafes works somewhat different. Everytime I launch hl.exe it is differetn application that starts from different folder. For example:

C:\Program Files\Steam\steamapps\valvecafepc406\half-life\hl.exe

When you exit steam, and start it up again it is like:

C:\Program Files\Steam\steamapps\valvecafepc2046\half-life\hl.exe

…and again, after steam restart it gets…

C:\Program Files\Steam\steamapps\valvecafepc34040\half-life.exe

Naturally, Comodo firewall sees this as a new application.
And everytime hl.exe is started, Commodo pops an alert. Because its always “another” new application that want access to the internet.

How can I set commodo not to pop up anything and let go of all from steam folder?
Thanks in advance.