Steam and the Sandbox


I’ve been going over this for a few days now, trying a lot of routines from FAQ and other threads, but sofar without tangible results.

After installing CIS 4 a few days ago, on a clean system (fresh image), a variety of games available through Steam no longer function correctly. Not all of them, but for example EVE Online as well as Civilization IV present themselves with issues, typically the application shutting down unexpectedly.

Considering the new sandbox feature, I’ve tried a few reinstalls (applying a clean OS image each time) with and without CIS IV, with and without sandboxing the applications, andsoforth. Common theme becomes clear: with CIS 4 installed, EVE Online randomly crashes, and Civilization fails to load properly in a manner which is unnervingly similar to the experience of trying to run XL Civ IV maps on a machine with not enough memory.

So, I tried running Civ IV through Steam without CIS 4 active (disabled for loading with windows), and Civ IV launches and loads fine. Now I try running Civ IV through Steam with CIS 4 active, it fails. If I disable CIS 4 (individually or completely), it fails. In a similar format, it makes zero difference whether either executable is marked as a trusted vendor / application.

All in all, that leaves me pretty confused, and somewhat frustrated. If anyone has similar experiences, or other insights, please feel free to voice these.

I’m sorry but I’m not familiar with these applications. What is Steam?

When you say you have tried things from the FAQ, could you say which FAQ and which things?

When you say you have disabled CIS completely could you say exactly what you have done?

This could be another guard32/64 issue, but its best to see if a more specific work-around will help first.

Sorry to so so many Qs, but I do need some more specific info if I am to help.

Best wishes



I’ve disabled CIS both via the configuration options (selectively chosing “disabled” from the right click menu for each element of CIS via the taskbar CIS icon), as well as disabling the CIS application as a whole by removing its entry from the startup list.

Steam, eh, the world’s largest gaming platform for sales, distribution and provisioning, by Valve (Steam, The Ultimate Online Game Platform).

As for FAQ, Ive gone over and through the various guides in the guides section of the forums, as well as the defense+/sandbox faq on these forums.

OK, actually you haven’t disabled CIS then. Or fully disabled D+.

Could you start by disabling the sandbox using the main GUI, Defense+ ~ Sandbox settings. Then Rebooting.

Rebooting is critical.

Then re-try the app.

Also could you check the C:\vritualroot<app name> folder to see if the are any games executables in it’s subdirectories

This will establish whether it is a sandbox issue.

Best wishes



sandbox disabled using main GUI, rebooted.
Starting Steam, works, starting game through Steam works.

No executables at all in the vritualroot. No folders either. Nothing.

OK, so it’s the automatic sandbox that is doing it.

Please switch the sandbox on again, reboot, start the game (or try!) and then take a screenshot of your D+ events, making sure that all information is visible, and post it here.

Exactly in that sequence please :slight_smile:

Do you have process explorer?

Many thanks


We would be grateful if you would add bug report information as requested here.

Best wishes