Stealth Ports Wizard Does Not Retain Setting; Is This a Recognized Bug?

It looks like COMODO might not be as secure as I expected. I keep finding the Stealth Ports Wizard sitting with the top radio button (of the three) selected, after I log off overnight and log on the next morning, every day. I have changed this to the bottom radio button as advised by the COMODO advice, time after time for months. I keep finding something has put it on the top button. Is this a bug, or is a virus/malware doing this? Does a Windows restart cause this? Am running COMODO Firewall 4.0.13877.779 in my Windows XP Pro SP3 x86 PC. I am not feeling expert enough to compose a policy that I could be certain would be good enough for the top radio button to improve security, better than to stay with the bottom button.

Should this be reported in the Bug reporting area? I haven’t reported any bugs before, and all I know about it is, that the moderators hate to get a bug report on something that doesn’t suit their criteria.

Please advise.

It does save and everything is working correctly as it should. This “issue” is known for a long while now, It’s by design, it is not a bug. :-\

If your global rules under

CIS-Firewall-Advanced-Network Security Policy-global rules

shows the attached entries, your firewall is ‘stealth’.

By default the Stealth Port Wizard opens in the first option.

[attachment deleted by admin]

Thanks for the Global rules, Layman. I have downloaded the file.

Kyle, OK, am glad to have your assurance that this behavior of the Wizard is normal and not a bug.
I would like to suggest, that there is a natural desire by users to confirm that our settings are in effect, and since the Wizard is the only view that we are given, that is where users will be looking. And thus, it would be useful to users if you all could either make a viewer to include this setting, or let the saved setting be the Wizard’s opening display. (BTW,you have a great avatar! Wish I could do something as good!) I guess I will try to find time to suggest this in the forum section for suggesting enhancements… probably will be after I get my 1040 done. :cry:
OK, back to work on issues. (I have another to post later.)


All I really need to know in life, I learned from
watching Star Trek.

“The best diplomat I know is
a fully charged phaser bank.”
– Scotty

I have the same problem, it says the settings are saved, but on opening the window again, it is always “Define a new trusted network and make my ports stealth for everyone else.”

In CIS > Firewall > Advanced > Network Security Policy > Global Rules, there are four entries:
Allow IP Out From IP Any to IP Any Where Protocol Is Any
Allow ICMP In From IP Any to IP Any Where ICMP Message Is FRAGMENTATION NEEDED
Allow ICMP In From IP Any to IP Any ICMP Message Is TIME EXCEEDED
Allow IP In From IP Any to IP Any Where Protocol Is Any

The first three have a green icon, the last one has a red one. Is this how it is supposed to be?


[attachment deleted by admin]