Startup Error - Unauthorized Publisher

I’ve been using Comodo Backup for about a year on my Vista Ultimate 32 bit machine with no problems. About a month or so ago, I started getting an “Unauthorized Publisher” message every time I start backup in a non-administrator account. If I enter the admin password, I see the global, admin backup jobs. I had configured backup to run seperate jobs under seperate accounts and it worked great until a month ago. If I log into the administrator account, Comodo Backup starts just fine without the security warning. I’ve tried everything short of disabling UAT to resolve this, including uninstalling and reinstalling Backup. I’m running Vista Ultimate 32 bit with Norton Internet Security 2008. Can someone help me with this problem?

So I tried disabling UAC, rebooted, and Comodo Backup started just fine in the non-admin accounts and ran the jobs set up for each of those accounts. But, other applications would not start properly without UAC (thanks Microsoft). So, I had to re-enable UAC. Does anyone know how to fix this?