Starts up open with no tray icon

Hiya all,
I have a problem i hope someone can help me with.

CIS5 was working fine up until a few days ago when it started to have the fault described below.
I havent changed anything on the PC in recent days.
So i uninstalled CIS5, then

I installed just the firewall of CIS5 and rebooted a few times, CIS was an icon in the tray and all was fine.
I then installed the Internet Security as well and immediately had the fault.

At boot CIS5 opens as an application but doesnt put an icon in the tray and if i close CIS5 it closes completely.
This has just started happening, any ideas greatly appreciated,

Hello Seekingtruth.

Try the following:

Open up the GUI of Cis and go to the MORE tab , then press the DIAGNOSIS button.
if there are any faults in the the installation of the program , this optiion will solve them
I hope this will help you to solve the problem.

Greetz , from Holland , Barry

hiya Barry,
Thanks for the quick reply. I tried it but it came back with no errors found.

Thanks again,

The startup command should include the -h switch to hide to tray.

c:\program files\comodo\comodo internet security\cfp.exe -h

does this help you any?

Wich version of windows are you using?
If you are using 7 , try the following:

press on the taskbar and then it shows , " show hidden pictograms " , then select " modify "…
if al goes well , you will get a list of programs , scroll down , untill you see the Cis pictogram… you are now presented with three options:

show pictogram and announcements , hide pictogram and announcements and the last:
only show announcements , obviously you have to select the first option…

as an alternative you can try to scan your pc for regisrty errors , for this you can use eusing free reg cleaner in combination with auslogics free reg cleaner…maybe these two show up with problems

no worries mate , glad to help you :wink:

Hiya all,
Thanks Barry for your reply, im running XP Pro SP3 with CIS5 working ok until this started. I havent changed anything, then suddenly it started with this fault.

Thanks John for your reply, adding -h to the CIS command line didnt make any difference.

As i have said this didnt start as an “install” issue, i had everything working fine and at boot CIS5 was always minimized to the tray icon as it should be.

This is a fault that just started to happen and as i havent changed anything on the PC i assume Comodo has changed something.

Awaiting your reply,

Hey seek.

I suggest you run a registry cleaner , like : EUSING FREE REGISTRY CLEANER , followed BY a scan with AUSLOGICS FREE REGISTRY CLEANER , these two work great together.
also you can try to use SYSTEM RECOVERY, and set your computer back to the time , before the problems have started.
Are you sure you haven’t any malware or spyware infection running , thats trying to prevent that CIS is running??
Try to scan pc with , MALWARE BYTES ANTI MALWARE , SUPER ANTIPSYWARE FREE and do on online scan with asquared online scanner ( these are the makers of asqared ani malware ) this service scans your pc for free and also gets rid of the ■■■■ for free…
here is the link for the free asquared online scan:

iobit has a free tool , that can check your hardrive for errors wich can be found here:

malware bytes anti malware:


eusing free registry cleaner:

auslogics free registry cleaner:

I hope my answer will solve your problems , if not you can send an email to comodo and maybe the can solve the problems , if the above solutions will not help you…
in any case let me know…
cheerz , Barry

Hi seekingTruth,

So :

  1. you install FW and Def+
  2. on top of that, you install CIS ie the AV and again FW and Def+

If it is what you did, the install is probably corrupt. Then uninstall and make a fresh install of CIS but not 2 times the same components.


Hiya Boris and all,
As i have said, CIS was working fine up to a few days ago when it started having this fault.
The process i used was, i downloaded the file cispremium_installer_x86.exe which has both the firewall AND internet security in one file. During the installation it asks what you want to install, the firewall, IS or both.

So i first installed the firewall , rebooted several times and all was ok.
I then started cispremium_installer_x86.exe again and this time installed everything.

After rebooting it has the fault of not loading properly.
I have uninstalled CIS completely and installed it ALL in one go, but still have the same error.

At boot the CIS GUI is opened as an application and/but there is NO CIS icon in the tray.

Any suggestions greatly appreciated,

Hi seekingTruth,

Have a look at this topic, it could help resolve your problem.


Hiya Boris & all,
Boris , I went thru the process at the end of the link tho its for the appl. CAS so i couldnt follow it exactly, after rebooting several times the fault still remained the same.

I tried once again to uninstall, reboot and reinstall all CIS from scratch, it worked exactly as it should for a day, then its back to the fault condition. This is becoming too complicated and time consuming. I dont have this problem with any other appl.

Thanks for your help,

I have a similar problem with the Comodo tray icon under Win7 x86.
Sometimes it simply disappears and I have to start the Comodo Firewall GUI through the start menu in order to get the icon back.
I didn’t care to report about this because everything is still working and Comodo is still doing its job in the background. Just without the icon.

Hiya Philee and all,
Ive come to the same decision, the firewall is running its just not putting the icon in the tray, ok i can live with that. If i need to access the GUI i just click on the Start/menu icon.

Whats interesting is that the CIS install is NOW NOT putting an entry in Start/menu ~ startup , weird ???

Thanks everyone,

Hiya all,
LOL you wont believe this, i decided if im going to have this problem i may as well put AVG2011 back on, i uninstalled CIS and installed AVG then CIS back on again and guest what , its working perfect ;D
BUT for how long , ummmm the next update i bet :wink:

Thanks everyone for your help :-TU

Hiya everyone,
LOL i can see the future ooOOOOOooo

I booted the PC today and CIS started an auto update then told me i needed to reboot, and guess what happened :wink:

Its a bit different now as it starts ok but the tray icon has become intermittent, sometimes the icon is in the tray and sometimes it isnt , I can live with that.

im open to any suggestions,

A member of the french forum had the same problem and solve it with a software called Taskbar Repair Tool Plus.

Did this useful article pass by already: How To: Fix Missing System Tray Icons at Windows XP startup ? If it did then apologies for spamming… :wink: