StackHash crashes with Spoon Studio due to Comodo Internet Security

TOPIC TITLE
StackHash crashes with Spoon Studio due to Comodo Internet Security

The bug/issue

  1. What you did:
    Installed “fresh” latest version of Comodo Internet Security and then ran Spoon Studio. The Spoon Studio application will NOT startup. It crashed.
  2. What actually happened or you actually saw:
    StackHash related crash (or likewise)
  3. What you expected to happen or see:
    No crash / application startup normally
  4. How you tried to fix it & what happened:

a.) First I thought it was a DEP (Data Execution Prevention) issue, so I disabled DEP entirely → no luck
b.) Disable all features from CIS → Firewall/Defense+/Sandbox → no luck
c.) Disable Comodo Internet Security Helper service (cmdagent.exe) → restart system → no luck
d.) Completely uninstall Comodo Internet Security → Spoon Studio works properly again

  1. If it’s an application compatibility problem have you tried the application fixes here?:

I have the latest version of Comodo Internet Security installed. I’ve tried all fixes.

  1. Details & exact version of any application (except CIS) involved with download link:
    Spoon Studio v9.1.1549.2, http://www.spoon.net/Studio/Download

  2. Whether you can make the problem happen again, and if so precise steps to make it happen: Yes.

a.) Start with a Windows 7 system without Comodo Internet Security installed
b.) Install the spoon studio version: http://www.spoon.net/Studio/Download
c.) Execute the spoon studio application as a pre-fingerprint to check that it works
d.) Close the spoon studio application
e.) Install Comodo Internet Security (5.5.195786.1383)
f.) Restart the system
g.) Try to execute the spoon studio application again
h.) Spoon studio will crash

  1. Any other information (eg your guess regarding the cause, with reasons):

Files appended

  1. Screenshots illustrating the bug: Appended

First I executed Spoon Studio before CIS is installed to verify Spoon Studio works properly:

Looking at the active processes with the Task Manager:

Then install CIS

Now restart Windows and check Comodo config

Check active processes via CIS

Execute Spoon Studio and application will NOT start up. Instead StackHash error pops up

Let’s remove CIS again

Reboot

Execute Spoon Studio; now it works again.

  1. Screenshots of related CIS event logs or the Defense+ Active Processes List: Appended
  2. A CIS config. report or file: Not applicable
  3. Crash or freeze dump file: Appended
  1. Screenshot of More~About page: Not applicable

Your set-up

  1. Comodo Internet Security: 5.5.195786.1383, No AV installed, Proactive config
  2. a) Have you updated (without uninstall) from CIS 3 or 4: No
    b) if so, have you tried reinstalling (if not please do)?: Not applicable
  3. a) Have you imported a config from a previous version of CIS: No
    b) if so, have U tried a preset config (if not please do)?: Not applicable
  4. Have you made any other major changes to the default config (eg ticked ‘block all unknown requests’, other egs here.): No, default config is used
  5. Defense+, Sandbox, Firewall & AV security level: D+=Paranoid, Sandbox=Enabled, Firewall=Custom Policy, AV=Not installed
  6. OS version, service pack, number of bits, UAC setting, & account type: Windows 7 Ultimate, SP1, 64 bit, UAC default settigs, Admin account.
  7. Other security and utility software installed: None, Windows Firewall Disabled
  8. Virtual machine used: No

[attachment deleted by admin]

We would very much appreciate it if you would edit your first post to create an issue report in line with the bug forum guidelines and format here. You can copy and paste the format from this topic.

To understand the reasons why we ask you to follow these guidelines please see below.

WHY WE ASK YOU TO FOLLOW THESE GUIDELINES
Bugs/issues can be impossible or very time consuming to fix if developers don’t have enough information to reproduce them. Since CIS is free, development time is limited. So if you want your issue fixed, please use the format below to describe it.

To avoid clutter, issues not described in the format below your post will not be moved to the ‘moderator verified’ issues topic. This means that the developers may not look at it.

Best wishes and many thanks in anticipation

Dennis

Hello Dennis,

I hope this modification is sufficient? The error is reproduced very easily.

Best regards,
Anton

have you tried running spoon studio outside the sandbox?
it is being run as partially limited now

maybe try this

Hello wasgij6,

I already tried. I also disabled all items Firewall, Defense+ and Sandbox. That doesn’t help either. Even disabling the entire service (cmdagent.exe) doesn’t help.

It is probably the low level stuff (Comodo kernel drivers) that interferes with spoon studio. And my gut feeling is that maybe even the DEP (Data Execution Prevention) in Windows is affected by the Comodo kernel drivers, although I cannot proof that currently. I don’t even know if that is (theoretically) possible.

In the meantime I’ve noticed at least one more application suffering from a similar issue, while it runs perfectly without CIS installed. So it remains very suspicious.

Thanks for your suggestion though.

Best regards,
Anton