ssl ca file problem

Hey Guys and hi Comodo.

We hosts, you can see our certificate on It works fine.
And we also develop a software, which can syncronize between our groupware and outlook. In this software we use Outlook Redemption and support secure SSL connections.

For that we have to give our software a certificate of the ca. I tried different one (and the one on our server), but non is accepted.

After that I tested connection with the openssl s_client. The certificate the server sends looks good. But I get the message “Verify return code: 20 (unable to get local issuer certificate)”; I used -Cafile parameter as well and write the correct path to the ca file, but problem still exists.

I don’t know, if you can help me, but maybe you had a hint for me how to fix.

Best regards

All you need is…

openssl s_client -connect -CAfile AddTrustExternalCARoot.crt

Which you can find here.

Hm, you’re right. It works with openssl. Thought, I tried it already, but thanks also.

I will see, if I get this working with our software…
■■■■, wont working. I see with Wireshark, that our software sends an unknown ca message to the server.