Splash screen at startup [RESOLVED]

Hi, what happens to me is that, irrespective of whether I check the button “show the application window on system startup”, each time I reboot the CPF splash screen opens up, and stays open, until I manually close it.
I have just installed release but the same behaviour happens, as with previous releases. Anybody can help?


This option determines whether CF is open at startup (interface is shown) or not. The splash screen will appear regardless of these settings.


Thanks. I guess this means I need to close the window manually every time? Does not seem to make much sense - to me at least


… or better still, uncheck this option.


Thank you for your help, Graham1, maybe I have not been clear. The option is unchecked on my CPF, yet after startup the splash screen continues to remain open - I need to close it manually and this seems a bug to me.


When you say splash screen, do you mean the application window? Now you’ve got me confused ???. If you mean application window, then yes, this shouldn’t appear. Try checking again, reboot and see if it re-appears (which it should). Uncheck again, reboot and then see if that does the trick. If not, then it may be a bug as you suggested.


What splash screen? I’ve never had a splash screen.


I don’t think the splash screen appears during normal bootup to the desktop. If you close CF and then re-open, it should appear then.



It’s possible, for some strange reason, that your startup entry for CPF.EXE is missing the “/background” option. This could, perhaps, cause what you’re seeing.

Hallo and sorry if I have taken my time to reply - force majeure.

I realize that there might be some confusion here, for sure I am now not certain of the terminology ???

What I mean is, that the screen attached in the image below appears and stays open. After the last post by Graham1, as I have seen something else appear and clese when I closed and reopened CF, I believe this is the application window, could you confirm?
In the program settings, the relevant box is unchecked [tried the handle suggested by Graham1 to no success].

kail, how can I check if it is the case of what you are suggesting, and how can I correct it?

thanks to all for your help

[attachment deleted by admin]

I am a new user, and the splash screen was unchecked by default for me. I don’t get the splash screen. (:WAV)


Yep, I know the screen you mean. Not, the splash screen. But, the main CPF screen.

Use MS Config (msconfig.exe) & view the Startup tab. You should be able to see CPFs start-up line in there & see if it’s wrong or not.

Unfortunately, to fix it… you’ll need to either reinstall CPF (yuk), use RegEdit (yuk) or use a tool, I recommend, StartDreck.


thanks for clarifying that we’re talking about the main CPF screen ::slight_smile:

Now I have used StartDreck and what I get is

»Registry »Run Keys »Current User »Run *Comodo Firewall=D:\-- SECURITY\Comodo\Firewall\cpf.exe
and also
»System/Drivers »Running Processes [...] +872=D:\-- SECURITY\Comodo\Firewall\cmdagent.exe [...] +2976=D:\-- SECURITY\Comodo\Firewall\cpf.exe [...] »NT Services *Comodo Application Agent CmdAgent running auto
I guess I have to use the Edit function in StartDreck, is it correct that I should use it on the *Comodo Firewall=D:\-- SECURITY\Comodo\Firewall\cpf.exe line? And if yes, can you post how exactly it should look like?

Thanks a lot!

Change this (via Edit in StartDreck)…

»Run *Comodo Firewall=D:\-- SECURITY\Comodo\Firewall\cpf.exe

…to look like this…

»Run *Comodo Firewall="D:\-- SECURITY\Comodo\Firewall\cpf.exe" /background

So, adding the double quotes (") & the “/background” option. Then CPF should load properly.

kail, I have done exactly as you suggested.

however according to task manager cmdagent.exe loaded whereas cpf.exe did not, and when I started it manually so did the main CPF screen and then it stayed open. Suggestions before I proceed with a reinstall?


Yes… using StartDreck, cut ‘n’ paste the CPF startup entry & let me have a look at it please.

kail, sorry for the delay in answering, I was away.
Here’s the entry (my programs are in D:)

D:\-- SECURITY\Comodo\Firewall\cpf.exe" /background
Thanks for all your help flash

Hi Flash, no problem with the delay.

Couple of things… the leading double quote (") is missing & is the directory “-- SECURITY” really where you have installed CPF or are you just masking it on the web?

It should read, assuming “-- SECURITY” is a real directory…

"D:\-- SECURITY\Comodo\Firewall\cpf.exe" /background

Hi kail,

no prob in following what you are recommanding, however have a look at the first entries in StartDreck log report:

»Registry »Run Keys »Current User »Run *Comodo Firewall=D:\-- SECURITY\Comodo\Firewall\cpf.exe" /background *ctfmon.exe=C:\WINDOWS\system32\ctfmon.exe *Spamihilator="D:\-- INTERNET\Spamihilator\spamihilator.exe" *TClockEx=D:\-- UTILITY\TClockEx\TCLOCKEX.EXE *Tray Commander=D:\-- HD & SYSTEM\Tray Commander\TC.exe *Uniblue Quick Access="D:\-- HD & SYSTEM\ProcessLibrary\qaccess.exe" /startup
These are all programs that *do* load at startup, and as you can see more than one does not have the " in front. BTW, they are all real directories ;D flash

No you’re right. But, all those that use double quotes (" or DQ) have a leading & trailing DQ. For things like this, DQs always come in pairs. You must have a start DQ & an end DQ. So, your CPF line…

*Comodo Firewall=D:\-- SECURITY\Comodo\Firewall\cpf.exe" /background
..should read..
*Comodo Firewall="D:\-- SECURITY\Comodo\Firewall\cpf.exe" /background
.. is that clearer?